V6 Text mask as background not working

text mask as background is not working, solid color mask works fine.
Know anyone why?

Thank you.!

It will work when you move the text up.

Thank you for quick reply, but its not solution. Bring forward i tried before i wrote question :wink:

Do not use BringForward command. Move it up (along z axis) using gumball or Move command.

Same result - and this is not acceptable solution. In V5 is mask ok in the same plane. Something is wrong in VR6.

I’m investigating this today and have logged a bug about it at


1 Like

I was about to but then found out that (1) I couldn’t get it to work as it should in RH5 and (2) I didn’t get it to work with solid color either (in RH6). That did work at one point though…

This is with solid color in Rhino 6 - the masking only works when the text is selected.

I do not have this problem.

I was afraid of that, yes.

In factory-default Shaded display mode, the mask covers the grid but not the line (unless the text is selected):


Rhino 6 SR4 2018-3-26 (Rhino 6, 6.4.18085.21321, Git hash:master @ e5071440f1175c39e2f4834d97d29e25c5b54a37) Licence type: Commercial, build 2018-03-26 License details: Cloud Zoo. In use by: Wim R.M. Dekeyser ()

Windows 7 SP1 (Physical RAM: 31Gb)
Machine name: KBG1WS206067

Quadro K3100M/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 385.90)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 10-30-2017
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Hi Wim - here too - thanks.


RH-43960 is fixed in the latest Service Release Candidate