V6 display error (black viewports)

unhandled

(Declan Halpin) #1

Firstly, is Serengeti still the best place to post V6 questions?

I just installed V6 last night (upgrade from V5). I did get the notification that I have several plugins that might be compatible, but I didn’t install any (yet).

When I start V6, all viewports are black. I seem to be able to make geomety - it isn’t frozen - but I can’t see anything. PluginManager shows no plugins incompatible with V6.

I’m using an GeForce card (will update this post with # when I get home).

tx,

dh


#2

I think the first thing to do is try updating your video drivers… --Mitch


Rhino 6 Raytrace crash
(Nathan 'jesterKing' Letwory) #3

Update also with results from Help » System Information please


(Declan Halpin) #4

Card: GeForce 540M
Drivers are up to date

Strangely, when I entered the OpenGL panel in Options, and clicked the down arrow beside Antialiasing, the black/unresponsive viewports went normal and the problem appears to have fixed itself even though I didn’t change anything. I’ll take it!

However, Rhino is using the laptop’s integrated video card. I’ve set it to use the GeForce in the NVIDIA control panel but it still uses integrated. Do I need to toggle something inside Rhino?

Rhino 6 SR3 2018-3-31 (Rhino 6, 6.3.18090.471, Git hash:master @ b32d93f452fce970e96deb46bfc68b075f06b290)

Windows 7 SP1 (Physical RAM: 7.9Gb)

Intel® HD Graphics Family (OpenGL ver:3.0.0 - Build 8.15.10.2342)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 3.0
Shading Language: 1.30 - Intel Build 8.15.10.2342
Driver Date: NA
Driver Version: NA
Maximum Texture size: 4096 x 4096
Z-Buffer depth: 24 bits
Maximum Viewport size: 4096 x 4096
Total Video Memory: n/a

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”


(Declan Halpin) #5

Semi-fixed - I actually had to rollback my driver. However, now I get a crash if I attempt to use raytracing. Also, geometry is invisible until/unless I toggle viewport display mode (wireframe to shaded, etc)

Rhino 6 SR3 2018-3-31 (Rhino 6, 6.3.18090.471, Git hash:master @ b32d93f452fce970e96deb46bfc68b075f06b290)

Windows 7 SP1 (Physical RAM: 7.9Gb)

GeForce GT 540M/PCIe/SSE2 (OpenGL ver:4.2.0)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 2x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.2
Shading Language: 4.20 NVIDIA via Cg compiler
Driver Date: NA
Driver Version: NA
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2096960 KB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino WIP\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino WIP\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino WIP\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino WIP\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”


(Nathan 'jesterKing' Letwory) #6

Your GPU isn’t all that powerful - you should try selecting the CPU as your rendering device for Raytraced: Tools > Options > Cycles.


(Declan Halpin) #7

Thanks, Nathan. Setting to CPU allows raytracing. A bit more info:

I downloaded a driver update from Dell (instead of nvidia) and now Rhino uses the nvidia card. However, I still see nothing in wireframe mode. Also, edges don’t show in shaded mode despite view settings being set properly.

This might be the motivation I needed to get a new laptop. :wink: