V. 7 and Geforce 2060: no rendering

Hi everybody,

since I use V. 7 the rendering und raytracing is unacceptable slow. A simple cube takes about 5 min…

here is my system info
Rhino 7 SR7 2021-6-9 (Rhino 7, 7.7.21160.05001, Git hash:master @ d2161989109d5dacba531310b5d345ce6f4da9f6)
License type: Studentenlizenz, Build 2021-06-09
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2060 (NVidia) Memory: 6GB, Driver date: 6-8-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 466.77
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-8-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Users\User\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\NVIDIADenoiser\0.4.1\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.7.21160.5001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.7.21160.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.7.21160.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.7.21160.5001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.7.21160.5001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Compared to what? Can we have the file of a “simple cube” that takes “5 minutes?”

If you have sun and skylight at the same time please turn off the sun.

kurven.3dm (245.8 KB)

I don’t have Flamingo - you should probably change to a supported environment.

Are you trying to render with Flamingo or with Rhino Render?

With Rhino Render I had no trouble rendering, even with the flamingo background.

edit: in the file you shared I can see you have Flamingo installed. Did you edit your _SystemInfo output before posting here?

I tried both, flamingo render and rhino render, nothing works proper.
No, I did not edit the system info.

Rhino 6 works very well, maybe I have do downgrade. But thats annoying cause of the money…

thanks for your help

You may want to try a clean GPU driver re-install. This is to ensure that a recent Windows update didn’t cause trouble for that.

Your GPU should work just fine with Raytraced and Rhino Render in v7.

something has to be wrong, this simple rendering took over 2 minutes. Reinstallt the drivers does not help.

Sun and shadows-only ground plane is currently suffering this performance hit. Turn off the sun and enable skylight (Himmelslicht) and you should get fast rendering again. It is on my list to fix: https://mcneel.myjetbrains.com/youtrack/issue/RH-64526

okay, thank’s for advise.