UV Editor Render Mesh


#1

When I go into the UV editor for a polysurface the unfolded render mesh doesnt show up on the rectangle i drag. I can drag a window and select the mesh faces and they highlight, but I really want to see them without selecting so I can, for instance, move individual faces around to align them with others. Any ideas? I’m confused because in all the videos/pics I’ve seen of the UVEditor process, the mesh shows up in black; very visible.

I should note that the meshes i want to see are very simple, as they’re for essentially planar surfaces, so each one has maybe 4-5 vertices

edit: added pics


(Pascal Golay) #2

Hi DefterGoose- does this happen even in a new file, with say just a box in it or something to unwrap?

-Pascal


#3

yes it does. I just tried opening a new file, making a box, and applying the dog image to it. Same result, I can highlight but cant see normally. I’ll try it with a sphere, to see if works for a denser mesh


#4

yep, same result.


(Pascal Golay) #5

Hmmm- Does a mesh object show normally (wireframe) in the viewport?

-Pascal


#6

Hi @defterGoose,

The wireframe (Mesh Wires) are displayed here regardless of the option made in the display mode. Do you have “show wireframe” checked in the UVEditor and Mesh Wires enabled from the display tab ?

ps. (not in relation to your problem) you may also run _Unwrap before opening the _UVEditor to get all uv islands connected at their edges.

c.


#7

@pascal - Yes. I can draw a sphere, mesh it, and delete the surface. It will show up in shaded and rendered.

@clement - I do have show wireframe selected and mesh wires as well. Makes no difference. As for unwrap, I’m not exactly sure how it does what you’re suggesting. When i run it, it changes the mapping, but doesnt make the image “flow” across the polysrf as desired. If the mesh faces showed as their supposed to in the UVEditor i could manually stitch the faces together to achieve this, but I can’t figure out a way to get Rhino to do this intelligently, which is weird. I assumed the default mapping behavior for a polysurface would be to keep the texture coordinates continuous (“differentiable”) across mesh edges.


(Brian James) #8

I’m having trouble reproducing this to tell why the UV meshes aren’t seen on your end. The only variable I can’t match from your descriptions is the ‘dog’ texture. It’s a long shot but maybe this texture is the cause. Can you try another or post this one?

In regards to using Unwrap. You shouldn’t have to select any edges given the simplicity of the meshes and the fact they appear to be open already. Please post a 3dm file with the mesh you are unwrapping if you still have trouble and I’ll take a look.

Lastly, if none of this leads to a fix for the display issue you’re having, please make sure you’re using the latest Rhino 5 service release SR9 and send a screenshot of your OpenGL page. This is in Options>View>OpenGL. I am still able to get the UV mesh to display even with advanced hardware display disabled but it may still be a factor.


#9

Ok, I was fooling around and tried defaulting the view settings for wireframe, rendered, and shaded. After doing this, UVEditor works as expected. Interesting in that I would assume the command should show the unwrapped mesh regardless of any other settings, as that’s its primary function. After defaulting these settings I can’t replicate the problem again. I suppose there I had some esoteric combination of settings that throws the command a curveball so it cant display normally. Oh well, the bug has crawled back into the haystack perhaps never to be found again!


(Brian James) #10

I like the metaphor!.. thanks for the update and let me know if this one sticks it’s head out at some point and you know what the settings were.

In the meantime, I agree that the UV editor should always display mesh wires. If I can replicate when it doesn’t, I’ll file a request to make it so.


#11

If you can post the geometry it would be helpful. From the image above i would say that the unwrapper must be able to unwrap it without any stretch or compression into one piece. There is one exeption: If you have naked edges, the faces of your polysurface may be unwrapped into multiple parts instead of one.

c.