Update unable to extract?

I get an error that the archive couldn’t be extracted. I’m on the latest public Sierra build.

I’m actually having this problem with a few of my other app’s that are trying to install updates. I’ve searched everywhere but can’t find a fix or even a mention about what the cause could be.

I can only make a guess. But it sure seems like the necessary compression software hasn’t yet made it’s way into the OS build.

Have you tried manually opening this file with some other option?

Maybe with a newly installed file compression program. OR possibly on a different computer running the previous OS X release? The later just being a way of checking if it’s possible under a more official OS build… which of course it should be – but if it’s not in your case, then maybe things shift towards the possibilities of a corrupted download.

if i goto any of the app’s, including Rhino, i can update no problem.

Could any of the file compression programs i have installed have become a default system unarchiver?

I was able to update 5.2.1 to 5.2.2 on macOS Sierra without any problems. Sounds like your changes to the compression programs might be the cause. You might try uninstalling them one by one to find the problem.

seems the GM release fixed it for Rhino.

Good to know. Thanks for the update!