How to disable the Rhino optimized viewport display of textures?

Hi,

often I run in the situation that a mapping looks good at the viewport, but not at the rendering. I got the info that Rhino is using a special optimization for the viewport, but this can’t be used for rendering. I want to see the critical mapping issues and like to fix the mapping issues by optimizing the mesh. But I need to see the issues at the viewport. Please help.

Is there a way to get the mapping so shown like it is be used for rendering? (Most I’m still working per Rhino 6 and VfR4.)

-Micha

@nathanletwory Do you know who could help here? Is it not the same problem for Cycles?

The Rendered mode doesn’t use UV-mapping when a specific mapping is used, but uses per-pixel mapping. That is why Rendered mode looks much better.

Right now for Cycles we also use UV-mapping, but eventually we’ll try to implement all texture mapping modes natively into Cycles so we don’t have to rely on UV-mapping when it is not needed.

Texture mapping rendering in Rendered mode is something @DavidEranen can tell you more about.

1 Like

@DavidEranen Could you please add an option, maybe hidden in the advanced option list, to disable this per-pixel mapping?

Why would we make it worse?

Because it is what the user will render per render plugins like V-Ray. It doesn’t help if the Rhino viewport shows an ideal mapping, which can’t be used for rendering finally. If there is way to use this perfect mapping for rendering than I would prefer it. I need to see what I can render.

Well, it could be used if the engine implemented support for it, of course…