Unwanted gaps in voronoi patterns. Something in settings?

Hey guys, I’m working on building some different voronoi spheres for a project. Super simple. Except every tutorial I try I end up with clusters of missing cells. Even when I download someone else’s sphere, cells are missing when I open it. I’m sure the answer is right in front of me but I’ve been at it all day and I can’t figure it out. Thank you!

Here are screenshots and the file of a simple tutorial I did (the 3rd one I tried)

voronoi sphere.gh (8.1 KB)

And here is a screen shot and file of a half sphere I downloaded. In the post where I found it no cells were missing. As soon as I opened it I got this:

And here is the file:
voronoihalfsphere.gh (14.6 KB)

The main thing I did to fix this was to use the bounding box instead of the split sphere for PopGeo.

voronoihalfsphere_2023Aug26a.gh (27.1 KB)

Of course, it’s not a “half sphere” as the GH filename implies, but that part is trivial to fix.

P.S. Here is a half sphere:

voronoihalfsphere_2023Aug26b.gh (26.8 KB)

Hi Joseph,

Thanks so much for your reply. I think you misunderstood the issue. This is not my definition. When I downloaded it, the holes appeared.

I’m sorry my work doesn’t help you understand the code.

When I open this file on MacOS, it works fine. When I open it on Windows, I get the same result you show.

I noticed an update to Rhino was available on Windows so I updated and it is working fine there now.

Current Windows Version 7 SR33
(7.33.23234.14341, 2023-08-22)


1 Like

I have Version 7 SR32 (2023-08-09).

Looked at ‘Help | Check for Updates…’ and it says “Your installation is the newest available.” Apparently because I am using “Service Release” (‘/release/win64/en-us/stable/’). If I try “Service Release Candidate” I see " A new build is available. Download now" (‘/release/win64/en-us/releasecandidate/’). :man_facepalming:

The bleeding edge…

Yeah that was the first thing I checked. Totally up to date. Thanks anyway!