Unable to save custom toolbar


(Willem Derks) #1

Hi,

I tried to create a new toolbar saved in my own UI folder.
When editing the bitmap, only something I drew showed up on the button (it did show in the editor but when I closed the editor the button did not change)

When trying to save the toolbar I got this dialog. Is it not yet hooked up or is it supposed to work?

HTH
-Willem


(Steve Baer) #2

@JohnM, can you help?


(Pascal Golay) #3

Hi John. Willem- this worked OK here- I modified a copied button’s bitmap and a new button as well, SaveAs-ed the RUI file and so far it seems to all work as expected.

-Pascal


(Willem Derks) #4

Hi Pascal,

SaveAs seems to (partially) work here yet Save on the new file does raise the error dialog.
Still editing the bitmap is not saved when the editor is closed…

-Willem


(John Morse) #5

Willem,

This it what the tool bar save code is doing:

  1. Writes current tool bar definitions to temporary file
  2. If the temporary file is successfully written then move the current RUI file to a backup file with the extension of “rui_bak”
  3. Move the temporary file to the RUI file replacing it.

The error you are seeing being generated during steps 2 and 3 and would indicate some sort of permissions issue replacing a file. As a simple test try saving the RUI file to your “My Documents” or “Desktop” folder and modify it and see if you still get the message. If the message goes away then it is defiantly a permissions issue either at the file or folder level.


(Willem Derks) #6

Hi John,

Indeed the files are handled OK when saved to Desktop.
However it’s strange that even when I save the file in the same folder where my V5 RUI files reside, I get the same error. Is there anything I can test to find the cause?

Thanks
-Willem


(John Morse) #7

Willem,

What happens if you try to manually reproduce the renaming steps using Windows File Explorer in your “D:\Rhino_files…” folder?


(John Morse) #8

I think I may have figured out the cause here, the function used to do the file renaming may be failing when the temp file and final files are on different volumes, I will test this and see if I can get it fixed in the next release.


(John Morse) #9

Willem,

I was able to reproduce this by opening and saving a file on a drive other than my C: drive and have fixed the problem.


(Willem Derks) #10

Great!

Thanks for the update on this.
-Willem