Unable to join Surfaces

I am unable to join the two surfaces in this photo, not sure why as I have used the same workflow in the past with no issues. How do identify the issue and resolve it? Thanks for your input.

Hello - use CrvDeviation on the pair of edges that you are looking to join - most likely they are more than 2X file tolerance apart. but please post a file with the surfaces if you cannot work it out, or send to tech@mcneel.com, with a link back here in your comments.


1 Like

Here are the results from CrvDeviation command however I am still not sure how to resolve.

In Options > Units, what is your modeling tolerance set to?
If it’s 0.001, then your curves are too far apart.
The deviation between these curves rounds up to 0.003, more than 2x your modeling tolerance.

This implies that one or both or the surfaces needs to be remodeled to fit more accurately.

1 Like

I have run into this type of problem using NetworkSrf.It seems the edges of the surfaces are not locked to the controlling curves in this command. I sometimes find they won’t join to surfaces that were made with the same shared edge curves. So the first step is to tighten the tolerance the surface is allowed to stray from the edge curves.
. edge curve tolerance

1 Like

That worked, looks like it adds a fair bit more complexity the surface.

Next might be rebuild the curves. I generally just use Rebuild.