Trying to multiply object 16 times, though only some of object shows

Hi, for my school project I am trying to rotate an object 16 times upwards. As shown in the image the green extruded object is what I am aiming to rotate multiple times, however when I try it only picks up aspects of the object and not the entire thing. Does anyone know how to fix this, I’ve tried multiple different things, and I haven’t managed to find a solution.

I have attached the grasshopper file of my current grasshopper script.


Test (17.4 KB)

be careful also for this, you are generating 16 vector values for move, then 17 angle values for rotate:

which results into the “last-moved-item” to be rotate by both the two last (and different) angles:

to correct that you can apply an expression of x-1 to the Steps input of the Range component, because n steps will always produce n+1 values

Hi Inno,

Thank you so much for your response, I have just tried your script and i’ve got everything to work besides the top two objects overlapping.

I applied an expression x-2.5 into the range which actually fixed the bottom bit (blue circle) however I am still having trouble figuring out how to fix the top two pieces overlapping. Do you have any ideas?

I’ve re-uploaded my current script in this message.

Test (37.0 KB)

What :interrobang: Any logic for that or just shooting in the dark?

here in A you have a number of geometries which are moved using 16 grafted vectors

this means it will produce 16 branches (from {0} to {15} ) each containing all your geometries translated by each vector V

then you are rotating those 16 branches of geometries just generated

because you have 16 branches, you need to supply 16 (grafted) angles

the problem is that you are still supplying 17 angles instead of 16:

it’s the Steps Input that you want to change into 16-1=15 by using a x-1 expression:

fast and stupid rule of thumb, easy to remember forever:

so because “16” is the final total number of values you want to get, the number of parts you want to divide is 16-1=15

another thing I would advice, but I think this is very much secondary, is to use a starting value of zero for your Serie of movement vectors, in such a way the very first item in your list will be moved by {0,0,0} so it’s just the original item

it would mean to input a zero, or to just remove any inputs (because default value is zero indeed) :

and here is what you get:

Test (40.6 KB)

to be fair, this definition is a bit messed up :smiley: but if it works then it’s fine :+1:

in case you want to investigate why that 16th element was rotating two times, these videos are for sure worth gold and every single minute of your time:


Hi Inno, Thanks so much for your help i’ve got it all working now. I also had a another quick question, I am wanting to create a set of 3 or 4 steps going upwards, each step moves 0.500 in the Y direction. I followed a youtube tutorial however it didn’t seem to work for my design and only the first step worked, I’m not sure if this is because my object is a plain rectangle.


Test (48.1 KB)

There is no “Y plane”. Y is a vector, not a plane. Perhaps you meant “in the Y direction”? Or is it “the negative Y direction”?

sorry just noticed the error, in the y direction.

like so?
Test file[fixed stepping].gh (52.2 KB)

My apologies I should have been more specific. Same shape as the design below

Test file[fixed stepping 2].gh (49.5 KB)

1 Like

thank you so much

1 Like