Trouble with imported curves becoming unjoined when applying commands such as fillet and rail sweep

I have been trying to make a logo design into a 3d version with a rounded look. my first approach was to import the illustrator file, extrude it and then apply a fillet.
the first problem was that the curve was no longer considered joined and i had to tediously select each individual curve segment before i had the whole outline selected to apply the fillet. the fillet failed horribly.
i then tried to go for a more manual approach by creating a quarter circle and using the rail sweep around the shape. again when i went to select the rail the curve had been split up even though it was joined when selecting it. as a result only a small portion of the curve was swept.
my question is: why are curves split up when using certain commands even though they seem to be joined when selecting them.can they be properly joined?
how can i create my rounded logo when none of the methods described have worked?
thanks for any possible reply’s.

Hi Danny - you can select all the curves and Join when they come in. But, AI curves tend not to have the cleanliness and continuity required to build good surfaces, so you may or may not need to spend some time with the curves in Rhino checking them for good continuity between segments (GGon command, CurvatureGraph command). Also, depending on what you mean exactly by Fillet, keep in mind that the fillet radius, in say FilletEdge must be smaller than the radius of the edge itself. Feel free to post or private message me what you’ve got and I’ll take a look.


1 Like

Thanks very much for your help Pascal. i managed to get a pretty decent result but i am still troubled by the tendency for rhino to split once joined curves into all of their composite pieces when asking for it to perform a blend for example. this is very time consuming and i wonder why it doesnt just ask for the original joined curve? is there a way to rectify this issue?
Thanks so much.

Danny, can you please post an example of what is bugging you? I’m not sure I’m getting it completely.