Trouble with Firefly:Grasshopper can not display data from potentiometer connected to Arduino

Hello everyone. I’m trying to reproduce the experiment made by the Youtube user edditive, which consists in changing the scale of an object using a potentiometer connected to an Arduino board. You will note he’s using Firefly plug-in, as I’m doing.

If you want to watch it, i will leave you the link:

I made the program exactly as he did, so I can get data from a potentiometer, but the ‘Uno Read’ node doesn’t display the data I need.

You will note that the Arduino board is well connected to Windows 10, and that the trouble is in the ‘Uno Read’ node.

This is the data i can get by executing the default potentiometer program in Arduino, AnalogReadSerial.

Thanks in advance for your attention and help.

PD: I’ve been trying to execute the Grasshopper files provided by Troy Baverstock, whom I thank, but, by the same reason, I’ve not been successful.

I tried to do this experiment, but the data from the buttons can’t be displayed.

Hi Joavogaco,
In your sketch you have your timer set to “1 second”, it would be worth trying something a lot faster - 1 ms or 20ms.
Also check your baud rates are the same.
If that doesn’t help, then please upload both your GH and Arduino sketches and a photo of your arduino circuit here.
Firefly with kangaroo.

Thank you, Drew. I learned I had troubles with Arduino sketch in the board. Nevertheless, I’m going to follow your advise once I’ve solved the troubles with Arduino board.