Trimmed surface with text not working - Kangaroo

I created this script where the definition is working with trimmed surfaces using primitive shapes but not with text when tried. Does anyone know or can guide through this?

The definition is attached below. (17.5 KB)

Your file didn’t include the other surface, but if you are using the same definition I would guess that the problem is with the meshing of the Brep. Also if you want to keep the curve on the mesh, avoiding the holes, it will work best to start with it not crossing any of the holes.

Seems to work fine with text cutouts for me.
Also - here’s a few small modifications to the definition. With this sort of curve growth, it can help to use a timer to increase the length slowly and steadily(to avoid the curve crossing over itself ) rather than doing it by hand with a slider. (26.5 KB)


I just tried again with the same definition. weirdly it worked.

Thank you so much!
I’ll check out the definition. Also, if I have a timer, how do I animate the growth and stop it at a certain point? Any tips on that?
Thank you

One way is to use screen capture software.
Another is to use a slider (without any timer), for the length/radius and then right click it to use the built in Grasshopper animate slider function. If using this option, you’ll need to choose the range for the slider and number of steps for the animation so it gives a reasonable rate of increase for the simulation. If using the BouncySolver, you can also adjust the ‘Iterations’ value to control how many simulation steps it takes between each captured frame.

Yup. Okay. Thanks :slight_smile: