Trim with BREP fail

I’m making this a new topic --since its a new problem that emerged out of the discussion here:

Can anyone explain why Trim With BREP is failing in this file? It constantly fails to remove one section of a circle which intersects the Brep… always the same intersection. Also HS_Kim reported that this same file is working on their machine… can someone else check to see if it fails on their machine too? I’m running rhino for mac --5.4.2. Could it be that this is a mac only bug? Can someone else test this on mac GH and see if it fails for them too?

Or… is there another way to accomplish this trim without “Trim With BREP” component? Any suggestions greatly appreciated!



Split with Brep (52.8 KB)

Quick test shows everything is working as it should.
Latest Rhino & GH on Windows.

Most probably it’s a CrvSeam problem. A face of the brep might be intersecting with the seam of the curve.

I still never solved this issue… does not seem to be a curve seam issue (in the attached screenshots the original circle endpoint is visible --well outside the trim area). Attached here is a GH file with a simpler case illustrating the problem. One wedge shaped Brep used to trim a single circle --if I rotate the Brep around the center of the circle the “inside” part of the curve which should be trimmed flickers on and off… in other words it fails for some rotational positions but not for others… similar happens if I scale the brep… trim area flickers on and off even if scaling is in the Z axis which should have no effect on the intersection.

If I put an “End Points” component on the “outside” output of the “Trim with Brep” --I can see that the failure always happens with the more clockwise face of the wedge shaped Brep… so in the the failed trim it is splitting the circle at the more counter-clockwise face but not the other --yielding a single closed “Circular Curve” with the seam moved to the one intersection with the brep. Seems significant that its always the same face that fails? images illustrating this attached…

I still have not heard form any other mac users to see if this a GH for mac bug… so far two windows users have not been able to replicate the problem. Anyone have any ideas for a workaround?

…If you need me I’ll be beating my head against the wall :wink:


Split with Brep fail (10.3 KB)

works fine with me (pc). I even tried heightening and lowering the unit tolerance but still no problem…

Ok, I just saw: Rhino 5
In Rhino 5 I had the same problem.
It seems that it is something you cannot avoid. Only workaround that I could think of is this: (16.3 KB)