Trim Region sometimes failing. Tried adding XY Plane

Hi folks, here’s an example:

Screen Shot 2020-06-22 at 7.49.20 PM

This is sometimes fixed when I add an XY plane to Trim Region, but not in this case. Keep running into this issue, would be great to find a fix.

Trim Region Failing Forum (536.5 KB)

Btw, are there any faster alternatives to Trim Region? I have a large program where it’s taking the vast majority of the computation time.


It works and only take 0.25s - whats the problem? For the scale of the task you are setting here, I think 0.25s is pretty good going. I tried a few other methods but they all came out taking longer, which isn’t surprising.

It doesn’t work though - see the image in my post.

Your posted image isn’t quite high res enough for me to tell whether the problem is replicating on your machine, but here’s what I’m seeing:

Works fine for me:

It’s probably to do with your Rhino model tolerance settings. You can change this in options:

Might also just be your GH view. Try baking the model and see if the same thing occurs in Rhino. Here’s the rhino file of the intersection on my machine:

Pattern.3dm (8.0 MB)

Change tolerance to 0.001 ; unplug Turrets and plug it again
or F5 (Recompute)
and check the duplicated curves

That did it! You guys are great.