Transferring Rhino as mass crashes Revit

Hi there.
I am trying to create a workflow that will take forms, created in rhino, into revit as mass forms.
It seems to work fine, until i start manipulating the form in rhino. I should also explain that i have also created a mass floor schedule in revit.
When i change the form a few times and then switch between tabs in revit, a Rhino dialogue box appears, with nothing on it, except a ?.
Then both Rhino and revit close.
image

Below, is the simple script i am using.

Any help would be appreciated.
I have tried without the template file and also unloading addins in revit.

Thanks
Aindrias

Hi Aindrias,

Please post your Rhino.Inside.Revit about info, i will try and replicate. Thanks!

Thanks for your swift reply, Japhy.
Here is the Rhino about info.
image

I have used the CTRL + Shift to open without any revit plugins-nothing loads. However, i get the same dialogue box appearing. If i choose the same options, it opens yet another session of revit (2024).
image

I did run system/Info. (See below)

Rhino 7 SR37 2024-4-16 (Rhino 7, 7.37.24107.15001, Git hash:master @ d2e42f70b9d3aa58f6053e2998a0db2abcd7555b)
License type: Commercial, build 2024-04-16
License details: LAN Zoo Network Node

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 64Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA Quadro T2000 (NVidia) Memory: 4GB, Driver date: 6-23-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 516.59
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

Secondary graphics devices.
Intel(R) UHD Graphics P630 (Intel) Memory: 1GB, Driver date: 3-3-2022 (M-D-Y).
> Integrated graphics device with 0 adapter port(s)
- There are no monitors attached to this device!

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-23-2022
Driver Version: 31.0.15.1659
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Users\AOh.MSP\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\SpeckleRhino2 (8dd5f30b-a13d-4a24-abdc-3e05c8c87143)\SpeckleConnectorRhino.rhp “SpeckleConnectorRhino” 2.19.1.15397
C:\ProgramData\Beam\App\RHINOBEAM.dll “MKS BEAM” 1.10.1.1
C:\Program Files\Enscape\Enscape.Rhino.Plugin-net48\Enscape.Rhino7.Plugin.dll “Enscape.Rhino7.Plugin” 0.0.24138.1238
C:\Program Files\SimLab\Plugins\SimLab USDZ From Rhino\SimLabUSDZExporter.rhp “SimLab USDZ Exporter”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.37.24107.15001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.37.24107.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.37.24107.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.37.24107.15001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.37.24107.15001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

I have turned off every addin in grasshopper. I am using the cage and CageEdit to manipulate a simple box, and push this to revit. I am getting this, every time i move a point on the cage.
image
I have just attempted to tab to a 3d view and received this:

Thanks for your help thusfar.
Not sure what is happening. As you can see, it is just a simple box.

Regards
Aindrias

Thanks for reporting Aindrias,

I was able to replicate. We believe this related to another issue that was posted no long ago and in the queue to be fixed.

Thanks for the update, Japhy.
I hope it will be soon :crossed_fingers:t2:
I will mark this as solved.
Regards
Aindrias