Thumbnail / Preview in file is not created


I have rhino 6 for Mac since one year now. I was using it on my MacBook Pro with Sierra, High Sierra and Mojave. Now I got a new Macbook with the latest OS X Version installed ( Catalina ). My Problem is: Since I changed the license from my old Macbook to my new Macbook, the Thumbnails are not visible anymore in the presentation of the file on my desktop or in the finder. I already checked the Mac settings of visualizing files inside the finder but this is not the Problem. Files are just presented with the Rhino symbol / Logo. As my order of files was just related to numbers, I have quite much trouble now to fastly find precise constructions that I could have find before easily by just watching the Thumbnail. :confused: Is there maybe an easy way to change that?

Thanks in advance


Hi Luk,

You mentioned that your View Options in Finder are set to Show Icon Preview, so this should work. I’m wondering if you can open one of the 3dm files that doesn’t display the preview and then save it. At this point does the Finder show the preview? My guess is that you have multiple Rhinoceros applications in your Applications folder and the last time the 3dm file was opened was with a version you’ve since deleted from Applications.

Hey Brian,
Thanks for your answer! Yes you are right. My view options are set on preview and it is still not working. In case of opening a file and saving it, there is still just the Rhino Logo visible. Earlier I transferred all the 3dm. files from my old MacBook Pro to my new MacBook Pro and installed the Rhino 6 version just once and for the first time on this laptop. I guess somehow you must be right that it has something to do with the two versions of Rhino on the old - and the new computer. But even if I am creating a new file on the new MacBook Pro and save it, there is still no preview created. Are there settings in the program settings, that allow you to switch the thumbnail on and off?

on this screenshot you can see, that the preview for the Fotos is working but not for the Rhino files.

The preview is I believe generated by an associated version of “quick look” that will install with the version of Rhino. Try restarting your Mac. Then open the 3dm in Rhino 6 and save it, any luck? If not, how about making a new 3dm file, does that generate a preview for you?

Sadly non of your advice are working. Creating new fils brings up the same Typ of Rhino files without preview. Maybe there was a problem coming up while I was installing rhino 6 on my laptop so that the associated version of “quicklook” doesn’t work properly. Maybe un- and reinstalling Rhino 6 is the only possibility. Any experience with the new Version of OSX (Catalina)? Maybe it doesn’t support the Rhino 6 quicklook version?

Actually I restarted it a second time and now all the thumbnails are visible. Seems like that was the solution even if I don’t know why it didn’t work out at the first time. Thanks a lot for your advice.

1 Like

I’m glad that worked after a second restart for you. Yes, I am also using Catalina here too.