The crash that shuts down your pc - never had this!

Im getting a consistent way to crash rhino in such a way that it shuts down my w10 PC without fault. No BSOD, no dump, cpu temp normal.

I thought it was GH, but i managed to corner it down to just rendering a geometry. Textures dont matter, just final draft quality, large sized objects and large render.

I updated the nvidia, cpu drivers, etc, same result. it’s not just with one file, but any high render settings.

If go to the render panel, set to final quality, press the render button at the bottom right. last render 3000x2000 was 13% done when it crashed.

After resetting the render panel, i believe it’s the environment or lighting was causing the issue.

i dont have other pc’s to test this on. But i do have models that had those settings - not sure i want to retry though…

I there a way to dump the memory that’s preferred?

i did go to “tech support” but didn’t see a relevant “post issue”, open ticket, only upload a file that fitted the need. I also saw some crash oriented posts, none helped, and hope some can guide me. Not sure this is the right place to dump sysinfos etc…


Assuming you are using Rhino 6 please start by copy/pasting the text from the Rhino command _SystemInfo.

If you want to share the 3dm file confidentially you can use . when the upload is completed I’ll receive an automated notification the file has been uploaded. Since tech support can see these files as well it would be a good thing to copy the URL to this topic in the comments section for the upload as well.

Rhino 6 SR22 2020-1-28 (Rhino 6, 6.22.20028.13281, Git hash:master @ 379871ece695dc096e83826f08b429db8ca2e7f5)
License type: Commercial, build 2020-01-28
License details: Stand-Alone

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1070 Ti (NVidia) Memory: 8GB, Driver date: 1-29-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 442.19

Secondary graphics devices.
Citrix Indirect Display Adapter (Unknown) Memory: 0MB, Driver date: 1-23-2019 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-29-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Users\Xavier\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.12.17.906\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Here’s the file, i select the handle and blade with the texture. The render settings seem right. Sorry, i lost the ‘default’ that was causing the issue and this is the render setting that got me in trouble… I’ll try to cause a crash to nail the model (after GH finishes its grasshopping).

Untitled.3dm (1.7 MB)

Not sure what you want to select in your attached file. You say the plane with picture material and then one of the handles? And rendering at 3000x2000 causes crash with Rhino Render at Final Quality in Rhino v6?

There’s a knife blade with a mapping, a hexagonal red and black handle. Might be hidden and those are the parts. The other parts are construction steps. But you got the parts right.

I used _Show to unhide all objects, then set Final Quality and did a render at 3000x2000. This worked just fine.

Any reason there is a Citrix adapter in the listing? Maybe turn it off and see if things improve?

The citrix is/was for work. Not in use.

What i saw however is that the rendering settings didn’t get saved in the file :frowning:
How do i saw them to the 3dm file?

I cleaned up the file to test - when im done with the rest (all saved)…