Textures not importing from one Rhino file to another

HI all… Maybe I am just stupid, but Rhino was capable of importing an object from one file that was mapped and textured into another file and keep both it’s mapping and textures… now it cannot do either, am I missing something I need to do before importing?

Thanks in advance for any answers. :slight_smile:

Update, I removed all other textures, renamed the texture and imported the object and it worked fine, but I am still having trouble with textures importing in general, it was not a problem before the latest update so I am sure there is something that has changed?

Something is up with textures specifically on meshes.

Rhino 6 or 7, and which specific version?

If you have a sample file which exhibits the behavior, I’m sure the developers would like it if you posted it here.

Thanks for the reply, the last version had some problems keeping textures on imported objects but this one has more problems, I cannot load any files due to a NDA, but this is what happens… I have a mesh with mapping on it, I have used this mesh before in Rhino and it worked fine importing or exporting the mesh… now it simply doesn’t work, if you do get a texture in by using the previous versions of Rhino it then loses the texture the moment you move the mesh, and it renders white in Cycles… also when you export a nurbs object from a file with more than one texture it exports fine, but when you try to import thet object or objects it picks one of the textures and applies it to everything… (I embed the textures so they don’t go missing later… this might be part of the problem but I need to do this)

I could make a test file but it would not make any sense unless you were to try the whole process, I import models and export models to various scenes all the time and only recently has theis been a problem. If I make sure only one texture is in the export file then the mapping and texture import just fine, but that will be very tedious considering the number of files I need to do this with.

Thanks again for your reply.

Version 6 SR29
(6.29.20238.11501, 8/25/2020)

Here is a simple test, in Version 6 SR29 Make a box, apply a texture using box mapping, then move the box… the texture stays behind, but the object moves away, this is not what used to happen… textures applied move with the object and can be exported with their mapping intact and the correct map assigned to the object even with multiple maps and textures in the file. So something has gone a bit screwy. :stuck_out_tongue: Also, where making a custom material used to have gloss finish and reflectivity work, they no longer function.

Quick update… Re-updated to Version 6 SR29 and the textures now move with the box… very strange. Renaming the non rendering texture to unnamed and removing the Use Alpha Channel from the textures allows the custom texture to have it’s gloss and reflectivity back. But not long after getting to that stage it once again loses the gloss and the ability to move the object with the textures attached? This happens after adjusting the textures using the Edit object texture co-ordinates function.

When you say “re-updated” do you mean that you re-installed, or do you mean you get the some behavior in a newer version than you mentioned above?

I still think that if you can make a sample file as you described

which you know produces aberrant behavior at your end and post it here, then the people at McNeel can have confidence that they are reviewing something that doesn’t work. It saves a lot of doubt about whether they are doing exactly what you describe if they try to follow your verbal description. If they don’t see it at their end that sets them on a different problem solving direction than if they see the same thing you do.

They would probably also want to see the output from your computer of Rhino’s system info command.

Hi, Thanks again for the reply, I did find a work-around, by making and mapping the objects and then exporting as an .Obj the maps are then combined with the mesh and when you import the mesh you have an object that textures adhere to, so you can move them without leaving the texture behind, and the gloss and reflectivity etc now work fine on that object. I have added a file that shows 3 boxes, you can move the first and second one and the texture moves with it, but the 3rd with custom mapping the texture stays behind when you move it…TexturesProblem.3dm (1.9 MB) TexturesProblem.3dm (1.9 MB)

Update, if you make a nurbs object, then use the Edit Object Texture Mapping Co-Ordinates to map the object, then export using the standard .OBJ export, then import and the object will have textures attached and you can move the mapped object without losing the textures.

I finally found the Apply button… which was the problem, so yes… as to my original question, I am just stupid.