Texture Map Renders with Landscape Contour Lines

This is the default texture on my projects. I don’t recall setting that, I think it’s a Rhino default texture or a VIsual Arq default texture. I could switch to another one and perhaps solve this, but I’d like to understand what’s happening here. As you can see, in the same Rendered Ambient Occlusion View mode, the texture is rendering ina way I’d never want it to, with contour lines in an ortho view. It renders as ridgelines on surfaces which are in fact smooth, which causes confusion.

I believe this issues is only related to View modes set to use Ambient Occlusion. And it must not be related to any texture mapping settings.

Here’s another example. In viewports from layout space, this dotted and ridged representation remains even when I change the material assignation for the object to anything else, including wood grain.

In model space it renders as desired in both ortho and perspective views:

Hello- that IS the ambient occlusion in action.


Thanks Pascal, but I’m confused. It’s acting in two different ways; in the detail it’s effectively adding ridges to a model where there are none, but it’s displaying correctly in the views directly into model space.

Can I get it to act in a detail view from layout space in the same way it is acting immediately above in the viewports into model space? It’s the identical View Mode in all cases.

Ah, yes, I see, sorry, I misread the images. Hold on a bit…
I guess one thing to try is disable VA, restart Rhino, and see if that makes any difference - I do not, so far, get the stepping effect here.


Thanks Pascal. It’s the same with VA disabled. My display drivers are both up to date.

Hello - does this happen with any object? Can you send a simple file that has this problem in the view? and export the display mode as well and send that…



RidgesInAO.3dm (1.5 MB) RenderedDGaoRidges.ini (11.4 KB)

Thanks, I see this here as well now.
@djhg - the problem is the view in your detail has a Z of thousands of units -

what I guess we are seeing is the stepping of the shading in depth but because the depth is split up into a finite and not very large number of zones - the depth occupied but the objects is a tiny splice of the overall view depth and only gets a few slices - at least that is how it looks to me. If I unlock your view and set the Z to say 500, the problem goes away.
I do not know if the developer can adjust how this space is split up or whatever… I’ll add it to his pile for a look.


Thankyou. That’s the source of the issue and I’ve corrected it also. I imagine there isn’t much call for camera Z positions so high on a project with these units.

The Z camera position in the plan Detail in the template I have created and am using for months has somehow been set that way, and since this artifacting only shows up at very large scales, I wasn’t aware of it. But in an ortho Detail, isn’t a Z position for the camera moot/undefined? Or does that depend on the Cplane settings for the Detail (I’m imagining a scenario where the camera is aligned along the y or x axis, or even obliquely wrt the detail’s Cplane)? I have no idea how I adjusted it, I wasn’t even aware of the possibility. Maybe you can set me straight on this.

It turns out that the coordinate settings on my ortho Detail Views have a mind of their own. They are all set to large numbers along their individual viewing axes. After I zero them in the input fields, the next time I activate the detail they jump back to those large numbers along the viewing axis, even if I lock the viewport in between. I am missing something…

Hello - the camera Z of a detail should adjust to the geometry in the file - can you tell if somehow there is something way above the World XY plane in your template?


Thanks. Clearly there are some “Pigs in Space” hugely enlarging the limits of this project. I should just get rid of them. But here’s a mystery: There must be many phantom objects in my template project (and thus all my recent projects…). After showing, unlocking, and deleting all selectable objects only 3 objects (and 4 detail views) are now selectable on the project, together occupying 3 layers. These 3 known objects are at 0,0,0. Zoom extents doesn’t expand to show anything else. SelectAll doesn’t select anything else. But 6 supposedly empty layers can’t be deleted because they report objects, most of which are blocks. Select Objects in Layer manager selects nothing when invoked on each of the 6 undeletable layers. Purging unused blocks removes 2 block definitions, allowing me to delete 3 of these layers. 3 mystery layers remain, reporting four objects. Deleting all block definitions (with no error messages indicating them being used in the project) still leaves me with one layer reporting 2 objects which I can’t get rid of.

That’s a total of 6 layers containing mysterious unselectable invisible objects including apparent instances of blocks which block manager deletes without error messages indicating no detection of instances of them in use in the project. 2 phantom objects still remain and camera axes coordinates continue to snap back to enormous numbers to accomodate them.

Hello - if you PM me your template, I’ll see if I can dig anything out.


Done, thanks.

In your template, I do not get the steppy effect. And in the steppy file with the huge z coordinate, I can fix it and it stays fixed - somewhere along the line to the full file you have that started the steppy display question and refuses to stay fixed, something has been moved a long way in Z… that is my only guess at the moment. You can send me the full file if you like, I am happy to take a poke at it.


Can you zero the coordinates for the target position and the camera position? For me, if one is zero, the other is light years apart. I can only do one or the other.

Try - just set the Z of the camera to some reasonable number like 100 or 500… and the target can be Z = 0. Does that stick?


No. It goes right back to 39910.8896. Rhino must think there are objects up there.

Just to clarify. It’s in the Template project that these pigs in space are recognized by Rhino. The same one I DMd to you.

Here’s the stripped down version of the Template version of which I sent you the complete one. There are two phantom objects on the layer called “Guides”. I can of course delete the layer and be free of the objects. And I will. But I want to understand what led to this and how to avoid it. All my projects from the last few months have these phantom objects and the wild camera positions.
MBSTEmplateExploration.3dm (1.1 MB)