Text-hatch not alligned when printing RhinoPDF

Dear All,

My colleague has a problem when trying to export/print as PDF.

The material to print is a combination of text and hatches. While everything is aligned in his rhino document, this is not the case when printing. The hatches get offset in the X axis in respect to the text. This only happens if we try to print as a Vector PDF.

I have no idea what may be the issue. We tried to open the same file on my machine and everything works fine. I was not able to spot any difference in the printing dialogue parameters between my machine and his.

The attached files show the off center file outputted from his Rhino and the correct file outputted by my PC.

Clichè_off-center.pdf (152.1 KB)
Clichè_Correct.pdf (171.8 KB)

Hi Nicolò -
Printing to PDF is very much related to the display capabilities of a PC. Please run the Rhino SystemInfo command on your colleague’s machine and copy-paste the result here.


He does indeed have a much older graphics card.

Here is the result:


Rhino 7 SR23 2022-10-9 (Rhino 7, 7.23.22282.13001, Git hash:master @ a931168ca9426920ae6aa97218710b662f17fc39)
License type: Commerciale, build 2022-10-09
License details: Cloud Zoo

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 18Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 550 Ti (NVidia) Memory: 1GB, Driver date: 3-23-2018 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 391.35
> Accelerated graphics device with 2 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-23-2018
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\LABUtility\RhinoNC\RhinoNC.rhp “RhinoNC”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.23.22282.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.23.22282.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.23.22282.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.23.22282.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.23.22282.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\BlockEdit.rhp “BlockEdit” 7.23.22282.13001


Hi -

Yes. For Rhino 7, 4 GB of VRAM is recommended.
The drivers are quite old and it’s worth a shot to see if the current version of those make a difference.
In the Rhino “Notifications” panel, there should be links to the site where those can be downloaded.