Text command causes Rhino to crash each time

Hi @pascal
I just type “text” in the command line, and nothing happens for about 3-5 seconds and then Rhino just closes and crashes and I get that dump crash file craeted on my desktop. I can’t get to the point when I can choose the font at all.
How can I start Rhino with no template, there’s always a default template right?

Try temporarily disabling TwinMotion, Lumion, and Enscape In Options > Plug-ins.
You’ll need to restart Rhino after disabling them.

If that stops the crashing, then enable them one at a time, restart and test, until you find it.

Any luck?

Unfortunately, it still continues to crash. I disabled all of them, restarted Rhino, tried “text” command and got a crash right away.
Any other troubleshooting I could do?

I think there’s a problem with my annotation as well, now when I tried to test it out, I also get a crash when I try to modify any dimension value. It may have something to do with fonts. Is there a way to reset the fonts somehow?

1 Like

Hi -
Did you ever try to run Rhino in Safe Mode?
Also, I’d try a Repair of the installation to see if that clears things up.
-wim

Hi Wim,
Just tried Safe Mode, same thing happens, crash happens right after I execute text command.
It’s odd because it happens to Rhino WIP version as well…

Where can I download the installation file once again, the one that I have from Rhino Accounts is pointing me towards 6.27 version, and my current version is 6.28?

These crashes might be related to Microsoft’s WPF library crashing when showing a dialog box, I think.

I speculate that this has to do with the version of the .NET framework that you have installed.

Can you please look in the registry for some information for me, please:

  1. Open Registry Editor (from the Windows Start button, type regedit, then press Enter)
  2. Browse to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full
  3. Tell me the Data of the Version value.

Thanks!

Update
Please also try running the text command without UI, by typing -_Text at the Rhino command line. Does that successfully create text without crashing?

Version value: 4.8.03752
Screenshot:

I tried “-Text”. It worked for a second, but then once I selected the text it crashed right after again.
Here’s a video of it:

@dusancv - I guess this does not crash if Properties is not open at all, correct? It crashes when you interact with Properties…?

Please try reparing the dotNet framework -

-Pascal

I tried, it doesn’t fix the issue.

For example, if I use it now with “-Text” I can create the text, but if I want to interact with it, I’d first switch to Layers tab, so the properties tab is not open, then I could normally move, copy, scale that text, but as soon as I double click on it or when I go to text properties, the crash happens.

Hi -

I take that applies to the repairing of the dotNet framework and not having the properties panel not shown?
-wim

Yes, I was referring to using .NET Framework Repair Tool. That didn’t fix the issue.

Just a small update. It seems as right now, the text command is working in Rhino WIP, but still doesn’t work in Rhino 6. Any ideas of what I could try next?

@dusancv a guy on our team, @lowell, is crashing in the same place that you are, and found that it’s related to a font on the computer. He had a font called “Scriptina - Alternates” that crashed every time the Text dialog opened. Do you have any third-party fonts on your computer?

1 Like

Hi @brian
Yes, indeed I do have third party fonts and I have quite a lot as I’m working with architects and designers that require the use of these fonts. So would you do some kind of fix/patch for this issue or would I need to uninstall all my fonts and do the troubleshooting that way? That would be a painfully slow process for sure :confused:

We’re trying to understand the bug and work out a fix now. I don’t have a good recommendation for you today. You can follow the progress of this bug here: https://mcneel.myjetbrains.com/youtrack/issue/RH-59311

1 Like

RH-59311 is fixed in the latest Service Release Candidate

I have exact same problem. Also it happens when I click dimension lines to edit them.

I can confirm that the issue is resolved. Right now, there are no more crashes when text command is activated. Thanks!

It seems Text and Dimension problems are solved after updating to SR28 through the link Brian offered. In my case, what I had been doing before were

  1. Nvidia Driver update - no
  2. Net framework repair - no( I just followed the basic process of the repair tool)
  3. Deleted 3 fonts that I installed most recently(Braille kind) - no unfortunately
    I use rhino quite occasionally these days so that I cannot pinpoint from when these problems started to occur but I can only suspect now that windows update or installing these fonts may have caused the problems.
    I’m relieved now. Thank you for the heartful advices from many!