Rhino 6 crashing when editing a text block

I have a new issue that just started. Whenever I try to highlight text in a text block I am editing it crashes. I tried in multiple files and it is the same. I sent a couple of reports. My Rhino and graphics card drivers are up to date. Any suggestions?

Hi Oliver -

Do you recall what changed on your system?
Please run the Rhino SystemInfo command and post the result here.

Here is the system info. I’m not sure when it started. I haven’t been using Rhino a lot lately so not sure what has changed since the problem started.

Rhino 6 SR21 2019-12-17 (Rhino 6, 6.21.19351.09141, Git hash:master @ 4d373f64ffb55e3a8d607d9618590728d86fb1e9)
License type: Commercial, build 2019-12-17
License details: Cloud Zoo. In use by: Oliver Moore (Moore Brothers Company)

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: DESIGN-LAPTOP

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro M2000M (NVidia) Memory: 4GB, Driver date: 12-6-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 441.66

Secondary graphics devices.
Intel® HD Graphics P530 (Intel) Memory: 1GB, Driver date: 7-1-2016 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-6-2019
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoCAM 2019 for R6\RhinoCAM 2019 For Rhino6.0.rhp “RhinoCAM 2019 - The cutting edge CAM plug-in for Rhino 6.0 from MecSoft Corporation”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCAM 2019 for R6\RhinoArt1FileExporter For Rhino6.0.rhp “RhinoArt1FileExporter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Thanks for that information, Oliver.
When you start Rhino in Safe Mode, does that procedure also crash Rhino?

Yes it does

@Alain - do you have an idea what to check here?


Not at the moment. @pascal, @wim, I gather that you can’t reproduce it?

Do you want to do a session on my comp and take a look?

Hi Oliver - do you get the crash report UI when Rhino goes down? If so, please send one of these in, with as much information about what you were doing, and check the box to send the file, if possible.
Does this happen in any file? A new file with just text? If not, if it is in some but not others, or with some fonts and not others, please send examples - either here, or to tech@mcneel.com if confidential, along with a link back here in your comments.


I’ve sent probably 4 or 5 files. I can do some more if you want.

It happens with old files and new. I can open a new file create a new text block, type anything and then try to highlight it with the mouse and it crashes everytime without fail. I always use the default fonts and haven’t tried changing them.

What do you want me to send for examples?

Hi Oliver - thanks for sending the crash reports - we do not need any more for now… so, if I understand, the crash is on selection of text in the dialog at the time you are creating the text to begin with, correct? (Not selection of a block of text as an object in the Rhino viewport…) And does this happen if you create text and then edit it later?


I first noticed it when I went into an old file and tried to edit a text block. So double clicking on the text block so the editor window pops up and then trying to highlight some of the existing text. After some trouble shooting I was able to figure out if I I tried to highlight any text (in a new or old file) within the text block editor window it would crash.

Hi Oliver - this should have been covered by the Safe Mode test from Wim but let’s make sure:
Open Options > Plug-ins page and disable RhinoCAM & RhinoArt, close Options, close Rhino, re-open Rhino - any different behavior?
I found a couple of crash reports, I let the developer know…


I sent the report with them disabled.

Thanks for your attention on this.

Hi Oliver - the developers think that your .Net is out of date - you might try:

  1. running Repair on the Rhino installation. (Windows settings > Add or remove programs > find Rhino in the list, click, choose Modify then Repair)
  2. Uninstall and then re install.


Still the same crash after I did a fresh installation. I uninstalled, rebooted, downloaded a fresh install from the web site and installed a new copy. Still the same problem.

Hi Oliver - can you check for Windows updates?
@curtisw - is a dotNet update on its own something to try as well?


@pascal the .NET framework is part of the OS, so it’d come along with windows updates. I don’t think it being out of date is the problem, the exception points to a corrupt .dll in the GAC (global assembly cache), which means a corrupt system.

Unfortunately, because it is part of the OS, only a windows update might possibly repair it (because this DLL is often updated). The closest thing I found to repair this is here, however you can’t actually disable the .NET 4.x “feature” in Windows 10 (only 3.5).

An option that might work (but is very dangerous) would be to find that same dll on another machine (with the same exact windows build), and copy it to that location… making a backup of the original if things go awry. The dll in question is this one:


Hope this helps!

However if this does, in fact, cure the problem then it does raise the question “how did it get clobbered in the first place?” and would suggest a hardware issue, perhaps a drive going bad.

um yeah.

I’d be more inclined to do a clean wipe of the machine…