Sweeping 2 Data Trees

First of all, thanks to whomever decides to take the time to try to help.

I have 2 data trees being used to create some “mullions” for a tower. However, when I try to sweep them, it does not give me the result I’m looking for.
One thing I noticed is that the line 0,0,0,0,0,0,0,0 from one list actually should coincide with 0,0,0,0,0,0,1 from the other. So the data from one list needs to properly match the data from the other.

I’m all out of solutions.

75 smooth.gh (42.4 KB)

the rhino file is uploaded here:

your GH use too many 3rd party plugin to deal with ordinary architecture modelling problem

from these fragments of GH components, and your description, I can not understand your intension.

also why tweencurve the 3 simple curve into bunch of them and loft?
this takes much time and makes no sense in architecture perspective.
proper way should be loft by 3 curve and generate the contour of them.

Would you draw some illustration on the picture?
What kind of mullion do you want?

Why use wetransfer? In light of the recent hacks related to MoveIt (a similar service), I am reluctant to touch that Rhino file.

And given the report from @11165, I won’t bother at all. I agree this looks simple based on your image, but apparently not the way you’ve done it.


Point Groups is probably what is disturbing data trees.

I would try to use a single Perp Frame at the origin of the interpolated curve (top data tree) and build your rectangle from there. You’ll probably need to align the direction of the plane to the tangent of the first curve, which you should have available somewhere.

I’m sorry. I’m pretty new to grasshopper. The reason I used the tween command through pufferfish is because the loft command would not give me the curves we needed, it would start curving too early. Tried Normal, tight, loose etc. I’ll try it again and see.

I tried to upload it through here but the file was too big even when zipping it. My apologies. If you don’t want to bother with it I can’t force you to. But if you know of a better way to send the file, I’m all ears.

Thank you. I’ll give that a try. I appreciate your help!

I have the rails in 1 tree, and I have the simple .2 x .5 rectangles in another tree. Just need to find a way to sweep them

I redid the script without the tween from Pufferfish and just a simple loft, and it worked the same. Thank you!
Now I just need to correct those mullions

That Rhino file sounds way too big for what your image shows! I’m surprised you need a Rhino file at all instead of creating everything in GH?

Here is what you should do:

  1. go here: Help Us Help You
  2. read carefully what it says
  3. upload your file following the instructions
  4. get help from all the people here that want to help!

Thanks everyone that helped. I simplified my script and that solved my glitch. Sorry to waste everyone’s time.