Sweep2 - Maintain height option doesn't work in Rhino 5


#1

I just upgraded to Rhino 5. Now when I use the Sweep2 command and check the “Maintain Height” option in the dialog box, there is no effect. The solid created by the Sweep2 tapers in both directions, exactly as when the option is not checked. How can this be fixed?


(John Brock) #2

It’s working as expected here.
Can you please post a file with your input curves so we can figure it out?
Thanks


#3

I have posted a test file with 2 sweer 2’s. The one at the origin point has the maintain height box checked, the other does not. They look the same.
Sweep2 test file.3dm (58.1 KB)


(John Brock) #4

Since your single profile curve is at the widest point between the rails, there is no height to maintain.
If your profile curve (or curves) were not positioned at this widest point between the rails, then as the rails continued to diverge, the height at the profile location would be maintained.

In my example, the profile curve was at one end of the rails so there was a height to maintain as the rails spread apart.


#5

Hi John,

Thanks for the explanantion. So you’re saying “maintain height” functions properly only if you start the sweep with a profile curve at the shorter end, preventing the height from increasing; but does not work to keep the height from decreasing if your profile curve is at the taller end? I am pretty sure it used to function in both of these situations. Maintain, after all, means to preserve or retain someting as it is.

Amy


(Pascal Golay) #6

Hi Amy - see if the attached makes any sense with what you expect. But when ypu sweep to a point, the setting makes little sense anyway, since the height has to be zero at the points.

MaintainHeight.3dm (87.3 KB)

-Pascal


#7

Hi John,

Yes, your file makes sense. I understand what you are saying. Good point about the setting not working when sweeping to a point. I don’t usually set sweeps up that way, but was trying to do a quick test file to show you, so you wouldn’t be confused by all the other objects in my actual model. Your explanation has fixed the problem, I just need to set the sweeps up differently.

Thanks again,
Amy