sweep1rail simple job fails why?...we have a bug


#1

Hi,
V5
see attached rhino file.

dead simple sweep fails.

sweeping an arc (cut circle) along a straight line with slight rise in its route toward rear.
select black line (rail ) then select the arcs starting at one end and working to rear (the slightly higher end)
preview shows nothing, shaded is on.
ok and see nothing.

why ?

If I select the front only profile it works, giving three separate surfaces.

Sweep1rail fail.3dm (26.7 KB)

Steve


(Menno Deij - van Rijswijk) #2

Weird, looks like a bug to me. All individual sweeps between two profiles are working, but the complete thing is not.


#3

Hi,
I just tried again, copy paste it into a new V5 file, still fails.

Copy paste it into a Rhino V4 new file, it works fine.

Definite V5 bug !

Created a new file V5, just draw straight line and chop up a circle and place along that line, sweep1rail, worked.

V5 doesnt like that object set yet V4 does.

I also tried loft, selected the arcs front to back and hit enter, got a channel with a gappy wavy centre, so thinking oops forgot the rail, did it again, and got a twisted manic shape.

Copy pasted the arcs and line to V4 , run loft, select just the arcs, hit enter and beautiful result. so didnt need rail.

whats going on ?

Steve


#4

V5 doesn’t seem to like the very slight angles on your polyline rail curve. If you check “untrimmed miters” in the options however, it does work fine. So does a Loft of the arcs either “normal” or “straight sections”.

–Mitch


(Brian James) #5

Check Untrimmed Miters in the Sweep1 dialog and you’ll get the same result as v4 here. The requirement appears to be due to the G0 continuity at these cross sections spots in the rail polyline…

I’ll ask development to take a look too, filed as RH-27998


#6

Hi,
Untrimmed miters, never ever aware of that and never ever needed it until now.

Would like to understand when one should reach for such a command. What symptoms to have initiating such usage.

Command help shows the shape appearing with Unrimmed miters on and also off. If it had said nothign appears then turn on untrimmed miters I would have realised :slight_smile:

simple sweeps worked for me until now.

It would be best if V5 acted as V4 on suc simple sweeps and rails…

Hope development can sort it as that issue just cost me an hour fiddling about and getting nowhere.

I am now into V5 territory and like the fact that the cursor issue I had with V4 on the vid card in my tower has been resolved, plus other benefits. but then there are some things going on I cannot quite put my finger on. and such time killers as this are a pain.

Do such fixes to this appear in updates…hope so.

Steve