Sweep1 Error: Trying to Sweep Sections from a List of Rails - Error


I am trying to Sweep1 a rectangular section profile with a List of Rails.

In the script, I generated lines by contouring a solid brep. Once Projecting the lines back onto the single surface (essentially splitting the lines by each surface) so that I can select only the lines per/surface, I tried to orient my Section Profile that I would like to sweep across the lines.

The problem is I can’t sweep and I can’t seem to figure out why.

Maybe it has to do with the plane? or Maybe it has to do with Grafting?

I also had tried extrude along curve and it resulted in “invalid brep”

Any help or advice would be appreciated.

Thank you!

ReferenceGeometrytoSurface_Sweep.3dm (46.8 KB) ReferenceGeometrytoSurface_Sweep.gh (38.6 KB)

Here is an image displaying what I’m trying to accomplish. :slight_smile:

ReferenceGeometrytoSurface_Sweep_re.gh (37.8 KB)

Thank you so much! @dowazura

The two components ‘discontinuity’ & ‘cull duplicates’, what function do those have? Does Sweep only work with lines? or ‘line-like curves’?

I also noticed you plugged in the number slider to construct a domain where x/2 - what does that do?