Sweep1 closed rail problem

When I check “untrimmed miter” option, ends of rail get a gap (I should turn this checkbox on)

Anyone can help me ?
220704_Sweep1_Problem.3dm (164.3 KB)

Hi @Adel1
Since your start/end point is right at a kink, sweep1 has to trim your surfaces in order for them to meet up nicely. If “Untrimmed miters” is checked/enabled, the command will only “continue” the surface as far as it can without trimming; and therefore leave a gap at the very end.
HTH, Jakob

1 Like

Thanks a lot. You saved me
Have a nice day