Sweep 1 rail problem


#1

Is this situation solvable or is it a bug?


(Brian James) #2

Hi violine,

This case works as you’d like with the style “Roadlike Top” in the Sweep options dialog. Does that help?


#3

Hi Brian,
it does not change anything if I choose “Roadlike Top” or any other Style.
Thanks!


#4

Here are both from another angle:


#5

yeah, I encountered something like this before. (the missing face shows the isocurve and that extra line is considered part of the surface upon exploding the sweep)

I believe I used the refit option to get it right in that particular situation (no example files from me… just saying I’ve seen it happen before)


(Brian James) #6

Hi violine,

Sorry that doesn’t work for you, can you attach your 3dm file? I made an example to try and reproduce the issue but your file is obviously different somehow.


#7

Thanks Jeff and Brian,
now it works:


#8

hey Brian,

here’s a file that should repeat the error.
sweep1error.3dm(65.0 KB)


#9

Hi Brian,
i didn’t found a solution here: Sweep 1 rail error no solution.3dm(31.8 KB)


#10

Hi Brian,
here I caught a detail of the problem and relates to the angle of cross section curve.
When using n. 1 c.s.curve Roadlike top style fix the problem, but with c.s.curve n.2 is not working.
Sample file: Sweep 1 rail error detail.3dm(41.3 KB)


(Brian James) #11

Thank you Jeff and Violine for the further examples. I have filed this issue as RH-20588. This report is not publicly visible at this time.

The angle of the cross section with this rail shape appears to be the variable that defines what will work and when you need to refit or use roadlike top. It may be possible to account for these cases with the default settings after development can look into it.

Thanks again for your testing and feedback.