Surfaces change / degrade when trimmed

Hi all,

I’ve spent the better part of this week trying to diagnose exactly how to prevent this issue from happening and have been unable to find answers. I have a model in which a beam must be trimmed in order to be matched with a corresponding length of beam. Unfortunately, when trimming this beam, the surfaces “jerk” into a different shape; the curvature changes and seems irrational. I’m unsure what could be causing this. Any help would be much appreciated!

Sections through the original and trimmed surface attached:

This could be a problem with too coarse a display mesh. Go to Properties > Mesh and see what the settings are. If the Mesh is set to Jagged and faster try Smoother and slower. If set to Custom increase density to 1.0. The Mesh settings control the mesh used for screen display, not the underlying geometry.

Otherwise post the file here.

That did seem to help it get closer! Thank you! It still is shifting a bit though. I’m attaching the file here . . . could it be a tolerance issue?

trimming issue.3dm (3.0 MB)

The actual geometry looks good. I used DupEdge and selected all edges of the Pre-trim and Post-trim surfaces. Then used CrvDeviation to check how much the trimmed edges deviated from the untrimmed edges. Answer is very little.

Another contributor to the apparent discrepancies could be the distance from the World origin. Try moving the geometry closer to world 0,0,0 and see if that helps.

Thanks so much for your help, David. It’s much appreciated. I’m creating it in grasshopper so I will move all of the inputs nearer to zero.

If I understand correctly, it’s (mostly) a display mesh issue and the underlying geometry is sound. Does this mean that the variation of the surface when trimmed will be within the tolerance set for the file?

Geometry calculations such as trimmed edges are entirely separate from the display mesh settings and depends only on the tolerance set in Properties.