Surface normals not extruding correctly

1_500 SCALE CNC_(WALID).3dm (3.7 MB) Hi everyone

I’m having a very frustrating issue with surfaces when I’m simply trying to extrude from a curve. My Rhino knowledge is limited hence this topic!

This file is for the CNC machine so when I export it to Fusion 360 these strange artefacts show up. They became visible in Rhino when I turned on the color for Backface settings.

I thought it was to do with the surface normals but after flipping them it doesn’t stop the issue either. Any ideas?

I’ve tried to fix it for two days but no luck. Not ideal for when you have an approaching deadline.

Hello Walid,
It looks like you’re having not just a simple curve but the whole or part of the curve duplicated.
You can try _Seldup command to find duplicate.
If it won’t work
Try _Explode command on the curve
Then delete the double.

Sylvain

(I m not in front of my computer it’s all I can see)

Thanks for your reply! I’ve tried and no luck. I’ll explain the steps I took.

  1. Extrude from curve - (the artefacts show up)
  2. Explode
  3. Seldup
  4. Delete the selection




You can try explode on the curve before extrude .
Then manually delete the double curve. Then join the curve again and extrude.
Good luck.
Sylvain

Thanks again, Sylvain. Unfortunately that hasn’t done it either. Even when I draw a completely new curve it still shows up like it is duplicated.

Ok i will look at your file tomorrow if nobody find the solution.

Sylvain

1 Like

Hi @Walid_Butt,

the display problem happens because you are working 530795.29 meters away from the world origin. Select all your geometry, type _Move, click on a point on the base and then enter a zero. This will move the geometry to the world origin. Then run _RefreshShade and all is well.

_
c.

1 Like

Thanks @clement!! I got the file from someone else and should have thought of that.

Thank you both for helping!