Surface does not align with edges

I gave a “waffle sculpture” file to my Laser cutting firm with many surfaces .
Each part is a surface trimmed, looking a bit like a comb.
The laser people found double lignes , (the surfaces do not align with precision to the edges. I had to "Duplicate edges and delete surfaces for them to be able to load in the Laser cutting machine. Is there any way to get the 2 to align. This happens when I save the file on DXF for the laser cutting Co to be able to cut the stuff.
Any one’s help- would be very welcome.

surface not lining up with edge.3dm (239.2 KB)

First, as you found out, do not export surfaces for something like laser cutting, only curves. A lot of laser cutting software will either not understand surfaces or get confused.

There is no reason I can see why duplicating the surface edges would result in a misalignment with the surface itself. Here the sample surface you posted looks fine. However, the surface is not on the Z0 plane, it is some 3000mm above it. This might also confuse laser cutter software that is looking for a piece that is flat on the world XY plane.

To resume, for laser cutting:

  1. Get outlines of any volume objects - if you have parts that have thickness, you will need to extract just the outlines in the form of curves (_DupFace border may be a way to do this easily). Delete the volumes.
  2. Get outlines from any flat surface objects (_DupBorder) and delete the surfaces.
  3. Flatten all on the world XY plane - _ProjectToCPlane, delete originals=yes.
  4. Export all the flattened curves DXF with the appropriate settings (check with your laser cutting supplier).

(the last step assumes that everything is drawn/modeled in Top view and all are parallel to the world XY plane. If you have parts that are oriented differently in space, there are various strategies to get them placed correctly on the World XY plane, depending on the situation)


Thanks. Very helpful.

My laser cuttng service still find errors in the file I sent them, I can’t see anything wrong, Would it be the way I “export selected only”, there is a list on the window of the DXF export shcemes, I export in “Default”, would it be another one, like 2004Lines, 2004 Natural…etc?

Corrected parts.dxf (625.5 KB)

First off I run the Convert command to convert all my curves to lines and arcs. There’s an option in the command line to do that. Then I export the file as a dwg with these settings.