Surface becomes transparent when joining

Can anyone figure this one out?

join.3dm (125.9 KB)

Just select all and press join and you’ll see what I mean.

the problem lays in this specific area shown below, when you use the command intersect you see that they are actually not fully intersecting each other, joining may then very well cause the display mesh to get irritated meaning you also may have problems later on. the funny thing is that it seems to join without naked edges.

it helps to use rebuild on the bigger surface with the same degree and same cp. joining then results in a clean join.

join.3dm (84.1 KB)

CrvDeviation is a handy diagnostic tool here as well. The edges are right around tolerance away - that should work… UntrimAll on the surfaces lets it work, but I’m not sure where the initial problem is.


  • I used a very cleanly rebuilt initial top surface.
  • On that surface I then used MatchSrf with “closest points” option and “refine match”.
  • That enabled me to join both surfaces.

I too am unsure of why Rhino thinks this is a problem after those steps.

I’m even more baffled as to why Rhino would ever produce a transparent surface when joining. This is not a bug?

What happens is the render mesh is bogus in some way - most likely, there is a tiny loop in an edge curve, and the mesh is being made in there and not on the obvious face.

The model, as you sent it has been joined at some point in the past - untrimming restores the edges.


Yes, ok… so this isn’t cause enought for a bug report? :slight_smile:

I must just accept that this simple surface, even if unjoined, rebuilt and rematched, will fail?