Subsurface subdivision problem

Hi guys! First of all I’m new with grasshopper. I’m trying to make my last degree project with grasshopper because he requires a parametric solution for the structure. It’s been really great, with alot of new steps every day to understand better the plugin.

Ok so. I can’t really explain why this is happening but I’ll try to be the clearest possible.

I’m creating a 6 vertices surface and I’m trying to subdividing with the isotrim/subsurface option. But everytime i trying to divide, I got this huge 4-side-subdivided-plane that goes beyond my geometry boundary. I guess thats because the U.V. coordinates ara messed up with this non-4-side-plane? I don’t know.

Right now I was trying to subdividing with a surface box and got the same results…

I’m trying to create a structure similar to New trade fair milan by Massimiliano Fuksas.

I’m attaching some example imagens to help the troubleshotting. And I didn’t find any place where I can post this in the grasshopper website forum… If someone can enlighten me so I can move this discussion to the website forum…

ps: Sorry for my English.

Greetings from Brazil! And so much thanks!

This is one of the most recurrent question regarding subdivision with trimmed or untrimmed surface.
See the link bellow to understand the underlying theory.
And I can show you one workaround way on this using Copy Trim and Surface Morph. (33.0 KB)


Wow… thats a really nifty logic to create this subdivision… I didn’t think that way!

I was trying to use the lunchbox panels division to create a trigid panel in this surface before I had this problem. I could just replace the isotrim with the panels component? The output still the same (untrimmed surface). It should work, right?

Btw, I read about trimmed surfaces and makes sense. But, should be another way you can make this operations more intuitive in grasshopper? (I’m not saying that your solution is bad, no way! But I imagine grasshopper could deal better with this subdivision, right?)

Thanks, really grateful for your help!

Update: Yes it worked with the panels! I was just plugging the wrong parameter in the surface to apply the grid…

Thank you again!