SubD vertex tag method not working properly

Hi all.

This might seems a grasshopper post, but it is mainly a rhinocommon problem, I guess. Rhino 7.
Setting a SubD vertex tag result in an odd shape. This can be fixed by moving the whole SubD, but it doesn’t always work, sometime you are left with a null or an invalid SubD.

In this simple case:
subd.Vertices.First.Tag = Rhino.Geometry.SubDVertexTag.Corner;
return the same result as this:

subd vertex tag (4.8 KB)

(I remember I did report this months ago, as well as other users…)

Please tell me if i’m using rhinocommon or grasshopper not correctly.


  • GH point deform still doesn’t care to work with SubDs
  • GH SubD components “Short names” (Full names option off) are messy:

    “Extracting” the identifiers are outputted as “I” but setting tags takes identifiers as “E” or “V” … make no sense to me.
    (Other gh components short names rarely make confusion like this)
    Imo changing output/input order or name shouldn’t cause backwards compatibility problems, as apparently not many users are using this components… as abc bugs like this are still present… :smiling_face_with_tear:
  • components to set SubD tags take the tag (crease/corner/smooth/etc) as single item, but identifiers as list! This is tricky because to set many different kind of tags you have to chain multiple gh components, and this is a different mentality than the rest of gh components.