SubD problems

Hello everyone,

I am having problems in smoothing the mesh of a lattice structure. When I create a lattice in grasshopper with the Intralattice plugin, the output is a very coarse, non uniform mesh. I figured that the workaround to that would be to further subdivide the mesh with the _Subdivide command and the run the QuadRemesh command in Rhino WIP. And it works, at least partly.
It shows no problems in creating a quadmesh on a 2x2 unit cell lattice structure, and does so fairly quickly with excellent results. I find that to get the desired result, I should set the target quad count to 150*unit cell with a 20% adaptive size.
However, since I need to run Simulations on the part, I need at least a 3x3 unit cell lattice structure. When I run the same string of commands, the quad remesh gets stuck at 75% and simply does not progress beyond that point.
I cannot understand the source of the problem. I know it can be a heavy task with this kind of geometry, but I have had way more complex simulations take way less time to solve.

Hi - without a 3dm file showing the problem, there’s not much that can be done here.

Coarse lattice.3dm (2.4 MB)

Thought I had attached it to the original post, sorry!

Hi - thanks for that file. I’ve issued RH-56422 so that the developer can have a closer look at this model.
I never get any progress beyond 0% on my system.

Have you tried creating the subdivided mesh with Weaverbird in Grasshopper? I think it would give you a less dense subdivision which might help you when converting. You could also further reduce your polygon count on the original Intralattice output before subdividing.

I have, but it simply does not smoothen the surface as much as I need it to.