Stretched UI tabs & viewport won't grow: V6

This happens periodically and I can’t seem to correlate it to anything. I have to close out and restart. I did a search for ‘stretched UI’ and "stretched tabs’ and didn’t find anything similar so apologies if this has already been solved.

Thanks for this post and report. Can you tell me if you are using a Custom Theme in Preferences? You’re in v6 so you are… the ribbon tab wasn’t the default in that version. Can you paste the results of your SystemInfo command here please. I have seen this intermittently and think it may have started with Big Sur. I’m trying to reproduce it for a bug report.

This seemed to happen again after I manually moved the window to the top left corner of the screen and tried to resize the window to be larger.

A new development: I was taking view captures of a 2-point perspective viewport (single) and it all of a sudden shrunk the viewport height significantly (not the window and the tabs grew like above.

Theme in preferences is the Rhino for Windows option.

SystemInfo:
Rhino 6 SR34 2021-2-3 (Public Build, 6.34.21034.07002, Git hash:master @ 2fec8130f097ca52a8bc9f334c3ed4a5921c5e30)

Apple Intel 64-bit macOS Version 10.16 (Build 20B29) (Physical RAM: 72Gb)
Mac Model Identifier: iMac20,1
Machine name:
Language: en-US (MacOS default)

AMD Radeon Pro 5500 XT OpenGL Engine (OpenGL ver:4.1 ATI-4.0.47)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8 GB
Graphics: AMD Radeon Pro 5500 XT
Displays: iMac (217dpi 2x)

Graphics processors
AMD Radeon Pro 5500 XT (8 GB)
iMac (2560 x 1440)

USB devices
Apple: Card Reader
audio-technica Ƞ: AT2020 USB
Apple Inc.: Magic Keyboard
Apple Inc.: USB-C Digital AV Multiport Adapter
Belkin: Belkin USB-C LAN
Apple Inc.: USB3.0 Hub
Apple: Headset
Apple Inc.: Ambient Light Sensor
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Apple T2 Controller

Bluetooth devices
Broadcom:
Nordic Semiconductor:

Third party kernel extensions
com.Cycling74.driver.Soundflower (2) 2D779840-7439-31E5-8A66-D786C3F47B75

Third party plugins
/usr/lib/swift/libswiftAppKit.dylib
/usr/lib/swift/libswiftCloudKit.dylib
/usr/lib/swift/libswiftContacts.dylib
/usr/lib/swift/libswiftCore.dylib
/usr/lib/swift/libswiftCoreData.dylib
/usr/lib/swift/libswiftCoreFoundation.dylib
/usr/lib/swift/libswiftCoreGraphics.dylib
/usr/lib/swift/libswiftCoreImage.dylib
/usr/lib/swift/libswiftCoreLocation.dylib
/usr/lib/swift/libswiftDarwin.dylib
/usr/lib/swift/libswiftDispatch.dylib
/usr/lib/swift/libswiftFoundation.dylib
/usr/lib/swift/libswiftIOKit.dylib
/usr/lib/swift/libswiftMetal.dylib
/usr/lib/swift/libswiftObjectiveC.dylib
/usr/lib/swift/libswiftQuartzCore.dylib
/usr/lib/swift/libswiftUniformTypeIdentifiers.dylib
/usr/lib/swift/libswiftXPC.dylib
/usr/lib/swift/libswiftos.dylib
/usr/lib/swift/libswiftsimd.dylib
/usr/lib/swift/libswiftAccelerate.dylib
/usr/lib/log/liblog_network.dylib

Rhino plugins
/Applications/Rhinoceros.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 6.34.21034.1002
/Applications/Rhinoceros.app/Contents/PlugIns/RhinoLabsTools.rhp “Rhino Labs Tools” 6.34.21034.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 6.34.21034.7002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/BlockEdit.rhp “BlockEdit” 6.34.21034.7002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 6.34.21034.7002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 6.34.21034.7002
/Applications/Rhinoceros.app/Contents/PlugIns/SolidTools.rhp “SolidTools” 6.34.21034.1002
/Applications/Rhinoceros.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 6.34.21034.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 6.34.21034.7002
/Applications/Rhinoceros.app/Contents/PlugIns/Displacement.rhp “Displacement” 6.34.21034.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 6.34.21034.1002
/Applications/Rhinoceros.app/Contents/PlugIns/RhinoRender.rhp “Rhino Render” 6.34.21034.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 6.34.21034.7002

Thanks for reporting this.

I experienced this once myself as well…but I couldn’t figure out how I’d gotten into that state. Once I restarted Rhino for Mac, the problem went away and I couldn’t reproduce it. Please do keep an eye open for patterns…if you can figure out how to reproduce this wonky behavior, please let us know.

-Dan

What is macOS 10.16 (Big Sur?), is this macOS version already supported by Rhino 6 or 7?

Hi Michael -

macOS 10.16 or 11 is Big Sur, yes. You can use Rhino 7 on this OS but not Rhino 6.
See Rhino - Rhino System Requirements for Rhino 6.
-wim

1 Like

I’ve been able to replicate this consistently. I often work in fullscreen and when I exit fullscreen and try to resize the window the tabs stretch consistently. I have to restart Rhino to get back to a workable window.

I experiences this again today, but I couldn’t, for the life of me, reproduce it. If anyone can figure out how to reproduce this - especially in Rhino 7 - we’d be grateful. I do see a number of crash reports coming in with descriptions that seem similar to this behavior, but I can’t be sure. In my case, Rhino did not crash.

Again, if anyone can reliably reproduce this, please let us know how.

Hello,

I am working on Rhino 7 and this issue is happening to me as well. It is consistently reproduced when entering and exiting full screen mode.

Super annoying as it is effecting my workflow and can not seem to make it go back to the normal ribbon.