Straight extrusion problem

When I try to extrude a drawing comprised of multiple (1000’s) small closed curves within a perimeter closed curve (sort of like a colander!) I’m experiencing a problem where the outer perimeter curve extrudes as a solid capped shape thus obscuring all the (also) extruded smaller shapes…meaning you cannot see the holes cut out within the overall shape. I have done exactly the same on many other drawings without any problem, but for some reason this one won’t behave! Any clues as to why.
Regards, Sebastien Boyesen

One possiblity is that the inner curves (holes) and the outer curve are not on the same plane… Or perhaps it is simply a display anomaly caused by meshing parameters that are not adapted to the “small” holes… Or something else… Only way to know for sure is to post the file…

Thanks for you reply…
I projected all the curves to the CPlane to ensure they were good…but no joy. This is something I have done many, many times with other designs similar to this…just can’t figure this out…
Here’s the file to look at
Thanks Sebextrusion test.3dm (9.4 MB)

Hi Helvetosaur, have you had the chance to look at the file yet? It’s very strange and I just cannot figure out why this will not extrude correctly…I need to extrude them correctly for rendering, so this is a bit of a problem.
Grateful for any light you may be able to shed on this.
thanks, Seb Boyesen

I get the behavior you describe with Rhino V5.5.4

It works as expected with Rhino Version 6 (6.19.19266.14182, 2019-09-23)

Also works as expected with the Rhino Version 7 WIP (7.0.19267.12036, 2019-09-24)

Spinning beach ball for about 30 seconds on V6 and V7 WIP while processing ExtrudeCrv command - not surprising, it’s working with a lot of geometry (2392 curves). At the end, the result is as expected - a solid extrusion with holes cut out for the smaller internal curves.

-Kevin

Thanks Kevin - appreciated…thought I was going mad. I’ll try the evaluation 6 download. Regards Sebastien

Sorry, had not seen the uploaded file. Here’s what I found… First instead of trying to extrude these curves directly into a solid, tried PlanarSrf to make a surface from them instead, I find this goes faster. Rhino was having trouble doing this, so I checked the curves. There are around a dozen very tiny curves - I used SelSmall with a value of 1 to find them - and as they didn’t seem to be adding anything to the design (they were more less invisible), I deleted them. I also adjusted the display mesh settings to make meshing faster.

Re-trying PlanarSrf after that, it still took around 30 seconds to make the surface. That looked fine, so I then extruded it. That also takes time, as Rhino wants to create a preview for the extrusion, which crawls when there is a detailed object. I usually use a special script that extrudes curves or surfaces a set distance without a preview to avoid this.

Anyway, after all that it seems to be fine.

image

Hi Kevin, thanks for your reply, but I’m still having the same problem with Rhino6 for Mac where the extrusion fails.
Could you please look at the attached file?

Much appreciated, Sebastien Boyesen

Extrusion error.3dm (3.95 MB)

Sorry for the late reply. My daughter had appendicitis so I’ve spent the past 2 days at the hospital.

I’m working with Rhino Version 6 (6.19.19274.01012, 2019-10-01).

When I open your file, select all the curves, and run _ExtrudeCrv I get this result:

If I draw a circle around your curves, select all curves, then run _ExtrudeCrv I get this result:

Is this the result you’re looking for?

-Kevin

Hi Kevin, thanks for your reply, and the continuing hunt to get to the bottom of this!
Neither of the results you showed are correct, unfortunately. I can get the first one, which would be right if it was capped (which I can’t)
The result I am looking for is to get and extrusion like this (i.e. everything black is the capped extrusion):

Hope your daughter is ok and gets well soon!

Many thanks Sebastien

Looking at your file some more and I think I’ve got the result you wanted:

Steps I followed:

  1. Open your file.
  2. SelAll
  3. Fair with Tolerance 0.1
  4. ExtrudeCrv

The Fair command alters your curves slightly, but at the scale of this model you have to zoom in a lot to be able to see it.

I tried this with Rhino V5 and it seems to work there as well.

Just curious - what is your workflow to generate these curves? You’ve produced some nice designs.

-Kevin

Thanks Kevin - at last that did the trick! Ive tried it on other curves that didn’t work, and by adjusting the Fair command it seems to sort it out. Out of interest, why would using the Fair command help this to work?
My workflow is to draw the designs out in Illustrator and import them into Rhino for CAD prep ready for laser cutting and export as DWG. The laser cutting software is quite particular and needs to have true CAD geometry. Rhino is perfect for that. We design and make all sorts of stuff - these are hot plate Trivets for the table! We finish them in rusty steel.

I need to have them extruded in Rhino so that a) I know the curve geometry is correct, and b) I need to be able to render them in Keyshot to show the Client.

Thanks very much for your help…much appreciated…

Regards Sebastien

Oak cylinder2.jpeg

I’m happy to be able to help. I’m somewhat of a newbie at Rhino - trying to learn by exploring commands I haven’t used before and following this forum.

Best explanation I can give it is that you need to start with the cleanest curves possible.

If you search this forum for “fair” there is a lot of good information. I found the advice in this thread useful:

https://discourse.mcneel.com/t/complicated-offset-surface-how-to-make-solid/39336/14

-Kevin

Thumbs up!