Stop GH Geometry-Pipeline from updating on 'hide' command?

Hi all,

I am wondering if there is a way to stop a Grasshopper Geometry Pipeline from updating when a ‘hide’ or ‘show’ command is executed on an element in the Rhino scene?

I use a lot of Pipelines to get data from Rhino, which works well. Often, at later stages in a model build, it is not uncommon for me be ‘hiding’ and ‘showing’ various bits of the Rhino model during QA/QC and editing. But: when I execute the ‘hide’ and ‘show’ commands in Rhino, I do not want the Geometry Pipeline to update and re-calculate the entire GH definition (after all, nothing has changed in the scene - all I am doing is changing the visibility of elements?). Is there a way to set the Pipeline to not do this updating on ‘hide’ / ‘show’? It should not update on a change to the visibility?

Note that when changing layer visibility, the Geometry Pipeline does not update. It only seems to occur when using the ‘hide’ or ‘show’ commands in Rhino on geometry elements.

any suggestions are much appreciated.


  • Macbook 2021, Apple M1 Max
  • OS 12.5.1 (Monterey)
  • Rhino Version 7 (7.25.22326.19002, 2022-11-22)


Hi @ed.p.may, can you share a simple file that shows this behavior?

Hi @Gijs

You bet: the simplest case would just be something like this I think:


Execute ‘Hide’ command in Rhino.

Note that the script ran, because the Pipeline updated when ‘hide’ command was executed.

(files attached)
example.3dm (3.9 MB) (2.4 KB)

all the best,

thanks @ed.p.may for the sample. I’ve logged RH-72326 Geometry Pipeline recalculates with Hide and Show

Ok: thank you @Gijs


FYI, This is still and issue and real pain in the neck on larger GH files (sitting and waiting for it to re-calc, just because you changed a small visibility setting). I have noticed that this also happens whenever you:

  • Change a C-Plane in the Rhino scene
  • Turn off / delete a Clipping Plane in the Rhino Scene


I’m sorry for that, it’s on the list to fix but I cannot give you an estimate when this can be addressed.

I’ve added that to the YT, thanks for reporting.

A temporary solution could be to add a data damn component between the pipeline and your computation logic. Not sure if that would be of any use to you but worth a try.

This problem appears to have gotten worse in the updated versions, so I’m logging yet another complaint about it. Now when layers are turned on/off, it will also also ‘fire’ the pipeline (not every-time, semi-randomly it seems).

I feel as though it is unacceptable to sit and wait several minutes for my scene to recalculate simply because of the change in the visibility state. I am requesting, yet again, that this error please be fixed.

thank you,