STEP file imports but geometry is distorted

#1

Hi, I’ve found there’s an issue with certain STEP files that are coming from CAD Exchanger software, if they are exported there with option “V2” instead of “V1”. The resulting STEP files with option “V2” are remarkably smaller and the exported STEP seems OK if I check it in other software than Rhino (Inventor, Solid Edge, Navisworks, etc.).

When I load the same STEP file in Rhino, the entire geometry model is distorted (randomly exploded).
image
I’ve tried to play with the import settings, but without any result. I’ve added an example of such a STEP file (converted IFC model):
231110AC11-Institute-Var-2-IFC_CE_v2.stp (5.3 MB)

Rhino 6 (SR7), Windows 10

(Dale Fugier) #2

Hi @mathib,

The current service release of Rhino 6 is SR12. Perhaps you should try updating you Rhino installation?

– Dale

(Pascal Golay) #3

Hello - your file looks incorrect in V6 here as well. I’ll add this to the bug pile, thanks for the example.
https://mcneel.myjetbrains.com/youtrack/issue/RH-51083

-Pascal

(Brian Gillespie) #4

RH-51083 is fixed in the latest Service Release Candidate