Static file display using .gItf and Amazon S3 bucket


I am attempting to share and static file hosted in a public Amazon S3 bucket. Attached is a copy of my script.

I am using the following metadata card and CORS policy.

Any ideas on what is not setup properly?

Meatdata card: application/octet-stream

CORS Policy:
“AllowedHeaders”: [
“AllowedMethods”: [
“AllowedOrigins”: [

“ExposeHeaders”: [
“MaxAgeSeconds”: 3000

After more digging it turns out that although I had the S3 bucket set to public, I did not have the actual file set to public. After making that adjustment we received the following error…

What is the maximum file size for external .gltf files?

Could you try following and let me know if it worked?

Maximum number of vertices per mesh is 65,536. Maximum size of all geometry sent to the viewer is 10mb for free and 20mb for PRO accounts, see more details here.

That url doesnt seem to be working for us. Can you verify my CORS settings look correct (see below)? I believe they are set correctly from the AWS link.

Also attached is the script we are running.

This documentation article covers all necessary steps to successfully set up external geometry and also contains CORS configuration example: