ShapeDiver external geometry

I have found your tutorial regarding the displaying external geometry. I try to do it, but without success.
I am not developer, so I didn’t catch some points.
How to add correct metadata to my URL? (point 2)
Do I have to use amazon server? Currently I use cpanel and wordpress.
I also didn’t understand point 4 (CORS configuration). Where I can find it to check it?
At the end, I tried your definition with replaced URL for model and texture and get messages:
Texture image download failed>SecureChannelFailure
Color texture download failed
Color texture saving failed

About the metadata and CORS configuration, you should definitely be able to do that using cPanel or directly by editing configuration files with an FTP client. I am not directly familiar with your setup, but here are a couple of links that should help:
How to enable CORS? (you should be able to add/modify your .htaccess file using the cPanel File Manager)
How to configure custom MIME types in cPanel?

About the texture image, it looks like a problem on your server, maybe it is not https-ready. Try to replace https with http in the url and see if it works. Alternatively, you should be able to configure your server for https.

I tried to use external geometry and to test it here: https://support.shapediver.com/hc/en-us/articles/360023743572-Component-Display-External-Geometry but without success.

  1. I creare .glb model and uploaded on Amazon S3
    Here is the link: https://s3.eu-central-1.amazonaws.com/test-external1/testexternal.glb stored on public bucket

  2. I made URL public

  3. I add meta data meta data as Content-Type = application/octet-stream for mentioned glb file
    (I also tried with model/gltf-binary without success)

  4. I click on “make public” in order to enable CORS ( I also tried to paste

  5. I paste https://s3.eu-central-1.amazonaws.com/test-external1/testexternal.glb in “file url” model paramters of your test external geometry.

After that, “businessman” 3d model disappeared and my model wasnt shown.
I also tried with your XFormExtGeo grasshopper definition, I uploaded it successfully, but I got only ShapeDiver logo on screen.

What I am doing wrong, how to make it works?

I tested your link in the demo, the console tells me it is a CORS issue:

It is not enough to set the document as ‘public’ in AWS, you also have to manually define the CORS configuration as described in the article. In your bucket got to Permissions -> CORS configuration and paste the header from the article:

<CORSConfiguration>
<CORSRule>
 <AllowedOrigin>https://app.shapediver.com</AllowedOrigin>
 <AllowedMethod>GET</AllowedMethod>
 <MaxAgeSeconds>3600</MaxAgeSeconds>
 <AllowedHeader>access-control-allow-origin</AllowedHeader>
</CORSRule>
</CORSConfiguration>

That being said, i uploaded your file on our bucket with all the right settings and the loading still fails. I tried to add a Content-Encoding ‘gzip’ metadata in case you used the compressing option but that doesn’t seem to work either. Can you send me (in private message) the CAD file you are working with and tell me which settings you used to export it to glb with the export plugin?

I sent you login details for my s3 bucket to check settings few weeks ago as well as email reminders, but still don’t have any answer nor explanation. Can you send any info regarding shapediver external geometry?

I will get back to you asap about your issue, I haven’t had the time to dig into it yet, sorry for the delay.