Split command & SelPrev with Rhino for Mac


#1

Thanks @pascal , This is how it works on MacRhino seems backwards from your description. I don’t get the option to add the value _SelPrev once i get the Select Cutting objects dialogue.

For me to use SelPrev it has to be the object to split.

I have my object to split selected …

I deselect …

Start Split command and enter SelPrev …

I hit Enter and it runs the SelPrev command …

I hit enter then select my cutting object …

Hit enter to run Split …

It works as you describe on Windows.

Can we get the Select cutting objects dialogue on Rhino for mac to be able to add a value? Eh @dan

Those will be selected when you run _SelPrev within the Split command.

Deselect previously selected objects. No selection when the split command is run …

Select object to split then hit enter to get Object to cut with command … and enter _SelPrev …

Hit Enter to run Split and close command …


#2

Thanks Randy.

I was not clear:

I understood Pascal’s words.

Then, speaking in general, I said that (after many years using Rhino … ) I’m still a little confused about commands run inside other commands …
Or maybe I just forgot about that … :smile:

Regards


#3

I get confused also :relaxed: and i just had to walk through it. It also showed me that I cannot do it the way @pascal described in Rhino for mac. So hopefully they can adjust this.

A presto,


(Pascal Golay) #4

So… is it working for you on Rhino for Mac?

Macro-ized: ! _SelNone _Split _Pause _SelPrev _Enter

-Pascal


#5

Hi Pascal, the macro works on the Mac.

I was just mentioning that I cannot enter the command in the Select Cutting Objects dialogue box.

For the Object to split I can enter a value …

But for the Select Cutting Objects, I cannot like on Windows …

Thanks, I will make a button for that!

«Randy


(Pascal Golay) #6

Hi Randy - hmm - works here…

-Pascal


#7

Ok, I am probably confused, were do I enter the _SelPrev once I have the Select Cutting Objects dialog box?

The macro works great,

In Rhino for Windows you can enter it in the command line. On the Mac version you there is no option to enter it. Am I missing something, doing it at the wrong time?

«Randy


(Pascal Golay) #8

Hi Randy - it looks to me like you can type it in the field in the dialog asking for a selection of the cutters, or just type ‘in the air’ - both seem to work here.

-Pascal


#9

Not working here, I tried that before I posted. I will try on Sierra at work tomorrow.

Straight Rhino or WIP?

Using …


#10

That is what I am seeing here, this is all I get for Select Cutters …

Thanks Pascal, Just finishing something and maybe I will try on Rhino 5.2 in a bit.

«Randy


#11

i think if your Object to Split is a certain shaped polysurface (one that isocurve extraction won’t work for ‘Select cutting Object’) …then you aren’t offered the chance to enter a value and the dialog shows like the one randy posted…

so, if you make a box then place a plane through it, the Split command works a little different (possibly incorrectly) than if you have two surfaces intersecting.


(Pascal Golay) #12

So… apparently you get different behavior if you’re splitting a surface with curves. There is a different dialog, I suppose because there are still options available. This seems incorrect to me - unless at the very least you can type in air, or a whole bunch of Sel* commands are not available… I’ll dig some more…

-Pascal


#13

heh, i think we typed that at the same time
:wink:


#14

Possibly, the little box is probably an extrusion. Doing this quick. Well if i explode and rejoin, still the same …

Well, if the box is exploded into individual surfaces I see a new dialog box …


(Pascal Golay) #15

HI all -

https://mcneel.myjetbrains.com/youtrack/issue/MR-2939

thanks!

-Pascal


#16

Well am glad this may help, because it would be nice to be able to type in the air. :relieved: