Spiral stairs problem

Having trouble with a construction that follows a spiral staircase. I’ve tried to create it using 2 interpolate crv that follows the outside and the inside of the steps, and then using a cross section doing a sweep 2. But the surface gets really bad. I’ve tried this method also with control points crv. No luck.

The second method i’ve tried is doing a control point crv that runs along the stair case touching the middle of every step. Then using slab command. The problem I have is not being able to make it the right width (only possible to type the width). It’s does follow the form of the stairs as good but the surface looks better.

Any better idea of how this should be done?

Can you post those curves or entire model?

SpiralStairs.3dm (15.4 MB)

will this work?


I’ve joined top and bottom points with lines and then used NetwotkSurface. The result is pretty OK and uniform.

I could give it another try using developable loft from Evolute, but only later as I don’t have it installed here.

Besides, your surface is displaying correctly here, without glitches. See image.

nice. Joined together? Is there a thickness to this surface? You do that before surface network or after?

but isn’t the surface jagged? It looks like that to me

Jagged is the matter of mesh display density. See your settings.
You don’t need to join the curves to run Network Surface, just select them in order.
To get the thickness you can create another set of curves and run the same command to make sure it follows the staircase main geometry. Offset surface won’t work properly in this case.

ok. what about the joining the two networked surfaces together - creating the two vertical surfaces between the to surfaces, making them a “solid”

No problem, if this is what you’re after.
You can use loft command to create sides or again: NewtorkSrf.
Good tip:
to get the thickness you need you can OffsetCurveOnSurface for inner and outer edges.
As an inner you can use staircase column as an outer you need to create an extra cylinder.

Thanks so much! this is amazing!

Hello - you have, if I understand you, the two curves that define the surface - if you Loft those you can then either OffsetSrf or ExtrudeSrf to make a solid…?


The different methods almost get the same result. But it looks like Surface Network toghether with Extrusion is a little bit smoother. But It could be, as pointed out by Piotr, a display issue. I haven’t figured out yet where to display the surface smoother. Tried Smooth & Slower in the Mesh-Setting. But is there a menu anywhere else I am missing?

Also don’t understand why i only get solid control points (8 total) on every end and not on the surfaces. They are polysurfaces and not extrusions.

thanks for all the help


Once you turn it into solid you can only control it by the corner points.
When it comes to display settings I always go for Custom set to 1.

Ok, I see. But the surface still seems pretty jagged

Options > Mesh > Custom > Detailed controls > Minimum initial grid quads Try a setting such as 4000 or even 10000…