Some object are invisible in Bella display mode

Hi @jdhill
Came back to try Bella4R again after sometime [of waiting for a new computer to come along, which hasn’t yet]

For some unknown reason, Bella renders some objects but leave other [the main part in this model] out [as invisible] …?
it is showing fine in Raytrace and Rendered mode [no setting are changed just the display mode]

  • I can send you the model privately if needed.

  • it is not immediately clear if the F4R version is the same latest one as the one in the website…? I updated from the website to 21.2.0

with thanks and best regards

HI Akash, the most likely reason is that the geometry has some degenerate data, from Bella’s point of view, so indeed I would appreciate seeing the model, to see (f this is indeed the case) what is the problem, and if there is any way I can deal with it automatically.

1 Like

Thanks for the model, indeed I do find this error reported by Bella as we try to start rendering (you should be able to see this if you have the console panel open while trying to start the renderer):

Bella: [ERROR] Invalid mesh(es) for object 7bc35484-90a6-40c9-8138-8c5c73a395f2: ON_Mesh.m_N[14360] is not a unit vector (length = 0).

The only workaround I have found in a couple minutes looking, is to use ExtractRenderMesh on the polysurface, and then run RebuildMesh on the extracted mesh. I have tried using custom meshing parameters on the polysurface, but whatever parameters I have tried so far, I still have that degenerate normal being generated.

So maybe you would be willing to isolate just that polysurface and attach it here, so the Rhino guys can also take a look and see why the mesher is generating this bad normal. And on my side, I will use the model to see if I can perhaps make Bella a bit more lenient, but I am not sure without looking into it more deeply.

Thanks a lot @jdhill
Yes it looks like there’s an issue here:

this was a closed SubD packed into a polysrf

rendering the original SubD shows everything

thanks a lot

1 Like