Solid Union Fails - Need Help

Hi guys,

Solid Union problems are quite widespread and right now I am facing another one. I have tried most of the recommended solutions. Changing unit tolerance of Rhino didn’t solve the problem. What is a possible workaround?

This is the model that I am experiencing the issue. Basically, I want to get a big solid that unions all the columns, beams and floors. Then I will do some calculations on them.

Solid Union Fail.gh (4.5 MB)

Your image doesn’t match your code. Did you notice that Clean Tree, Brep Join and. flattening the input to SUnion are unnecessary and do nothing?

Item zero in your list of breps looks very weird as it appears to be four separate pieces, yet selecting one selects them all, even when baked? But culling that one out doesn’t help.

missing

Neither does scaling all the breps up from their centers slightly to avoid co-planar faces.

Boolean Union in Rhino of the baked breps, culled or not, also fails.

Your image doesn’t match your code. Did you notice that Clean Tree, Brep Join and. flattening the input to SUnion are unnecessary and do nothing?

This was a desparate attempt after I tried everything @Joseph_Oster .

This model came from Revit through Rhino Inside actually. So the breps shown in the image are Revit floors drawn as a single sketch in Revit.

I also tried scaling all from their center, as well as Boolean Union in Rhino. Couldn’t find a way to do it.

The issue Joseph brought up about a brep with multiple pieces can be solve by deconstructing then joining the faces, but even then you can’t union them.


if you try the union in Rhino, it’ll tell you why it failed: Intersection curve ends at a non-manifold edge.
I don’t know how to solve this issue tho. Maybe scale these problematic beams slightly length wise?

1 Like

I have tried scaling each item by their center slightly and reunion them. Got the same error though.

Boolean union set is empty.

When I try it in Rhino it just says Boolean Union failed.

Basically the only problem I see other than single brep with multiple pieces, is the non-manifold issue.
You have too many of these:


simply scaling each of these problematic beam manually solves the problem, so I don’t know why it doesn’t work for you
Untitled.7z (2.3 MB)

you shouldn’t have this issue of beams not connecting properly if the model came from revit??
as far as i know, in revit beams lock onto columns and sits flush, maybe you want to pay attention to how you’re modeling in revit?

I have fixed the issue of single brep with multiple pieces. But it doesn’t work anyway.

I have tried to avoid second issue by scaling each item slightly and make sure that all breps are intersecting but issue still persists.

I have tried to create a loop but couldn’t find my around really.

I really don’t know why it doesn’t work for you, as you can see in the Untitled.7z file, scaling problematic beams solve the issue when I tested it, in the file previously attached is the single brep result from booleanunion

How did you find non-manifold edges? I couldn’t find it with Edge Tools in Rhino.

did booleanunion in rhino, when it fails, you’ll get a text dot, highlighted in my first screenshot, that’s where non-manifold edges are.

1 Like