Snapshots increasing file size even after deleting

I created few snapshots to try out something in Rhino and after saving, the file drastically increased its size from 13MB to 18MB.
Even after deleting the snapshots and saving the file again, it shows around 17MB.
Also, while batch rendering in Vray, it shows some snapshots and animation which are created inside the file. I don’t know how to clear or remove those.
Any idea?

Similar issue posted abotu earlier this week: How to render 20 layer states per V-Ray?

That thread doesn’t mention about the increased file size even after deleting the snapshots. Any idea?

After you deleted the snapshots and saved the file, did you re-open it?

Yes, I did. The file size remains the same.
I also tried adding one snapshot which increased the file size from 13MB to 16MB. After deleting and saving the file again, the file size remains 16MB only.
Only if i undo the screenshot and save the file, it goes back to 13MB.

Hmm. The dev who created snapshots is aware of the issues with this. There has been internal discussion on how to tackle this, but at the moment I don’t think there is a good solution. You could try saving as a new file with the Plug-in Data checkbox unchecked. But that will also remove any V-Ray plug-in settings from objects/materials.

Oh, alright. I tried purge also, but it didn’t help. I guess I will continue with this file as I would require the current V-ray setting.

Thank you

Just tried saving without plug-in data. The file size reduced to 5.XXMB.

I think I offered a reasonable solution for this to @lars a while ago; unless it is technically difficult, what’s wrong with letting the user decide and be responsible for the data they need saved per snapshot?

It is more about ensuring snapshots current code doesn’t break, do extensive testing, and resource availability (time). They all will converge at some point though, but no ETA as of yet.

that sounds better, because I think solution is there, but obviously needs time to implement.

I was super excited about this feature in V6 and tried to contribute a lot to testing and suggestions in its earlier stages. Unfortunately now simply can’t use it at all because the implementation that saves all the data for each snapshots makes it impossible to work with due to file size bloat. Really hope a fix for this will get a high priority as you can see this is an ongoing issue that keeps popping up from users not aware of it.

@lars, @nathanletwory - thank you for fixing Snapshots to prevent file bloats - I saw in on latest WIP updates list… didn’t test it yet but I am very excited for the possibilty of finally starting to take advantage of this great tool…



@Jarek let us know what you find, including any bugs of course :wink:

1 Like