Small BUG: Annotation Styles

On my system, UNDO appears to screw up styles. Here is a sequence that causes the problem for me.

  1. Draw a line vertical or horizontal line (1)
  2. Do offset something like 10-1/64" with a small fraction that is not within the resolution of the default style (Line 2)
  3. Do DIM between then ends. It shows a dimension that is rounded up.
  4. Draw another line anywhere (Line 3)
  5. Do File>Settings and change the annotation style length measurement to use 1/256 as the resolution.
    [Now the dimension should be exact.]
    Do UNDO until Line 3 is gone (twice).

At this point the line style still says that the resolution is 1/256 but new draw a new dimension and it uses the original resolution (e.g. 1/4).

Now manually change the FILE>SETTINGS resolution and new dimensions will use that resolution.

It appears to me that what is being displaced in the settings and Object Properties are not being kept in synchronization with the actual settings being used.

Can you have a look at this please?

1 Like

Hi Miano,
These steps get quite complicated.
I tested with the Mac Version 6 (6.27.20139.16402, 2020-05-18)

These setting are all independent in the model:

  • Model Unit/Model Tolerance (It simply a way of stating how much precision you need, or conversely, how much error you are willing to accept in your project.
  • Display Precision (affects the display of Analysis commands and Status bar)
    This does not change the true size of the objects, they are always as accurate as you input them. However, you can round off the display of the length or distances.
  • Annotation Style Linear Unit and Linear Resolution
  • Object Properties Annotation Style Overrides: Linear Unit and Linear Resolution

Which setting are you referring to? Units or Annotation style?

We are not seeing or not understanding the issue.
Here is a screen capture video of what we [tried]my model.3dm (3.5 MB) (
The model that I used for testing is attached as well.
Let us know if we missed anything.

Thank you.
Mary Ann Fugier

I was doing FILE>SETTING>ANNOTATION STYLES (Style selection)>Length Units>Linear Resolution

Hi Miano,
Please watch the video and let us know if we are experiencing same issue.
I did not see anything that I felt was unusual.

Try my file as well.
Property overrides will stick with the dimension, until they are removed.
The property will not update with the Annotation style until the overrides are removed, as well.
This is true for Windows and Mac Rhino,

Mary Ann Fugier
McNeel Technical Support and Training
Seattle, WA

1 Like

I think can show the problem without the bandwidth of a video.

(In the initial default state, the linear resolution for the dimension is 1/4". If you have made it much smaller you need to change it for this exercise.)

  1. I draw a line

  1. I do OFFSET giving a value with a fraction smaller than the linear resolution of the dimension (Here 48 1/32").

  1. I draw a dimension. The dimension is rounded off from 4’-0 1/32" to 4’

  1. I draw another line. This has nothing with the problem but helps reproduce it.

  1. I change the linear resolution of the dimensions to make them small enough to show the fraction (Here 1/64").

  1. Now the fraction shows up in the dimension.

  1. Now I do UNDO until the third line goes away (the only purpose of the third line is to show the right number of UNDOs). The dimension goes back to leaving off the fraction.

  1. Return to FILE>Setting and

The linear resolution is still 1/64".
But in the Properties the resolution for the object is 0 1/4"

If you play around at this point, you find that the resolution for the style is 0 1/4". The bug is that the resolution shown in the dialog box does not reflect the actual resolution of the style after an UNDO.

(Seems simply when you unravel the steps but when you see 1/64 in the resolution and you are drawing dimensions with 1/8-1/32 fractions and they are not appearing, it is frustrating.)

Hi Miano,
Thank you again for your patience and additional detailed steps.
Good news, I have been able to duplicate the issue in both Rhino 6 and 7.

I have logged issue RH-58714
If you register on the YouTrack site, you can watch it as it progresses through the fix and testing phases.

Kind regards,
Mary Ann Fugier
McNeel Technical Support and Training
Seattle, WA

1 Like

I have not yet figured out how to reproduce this, but I think it reflects the same general issue of things not being maintained consistently.

I created a new dimension (highlighted). According to the object properties, the dimension style is “Small Decimal”. The “Small Decimal” style is Inches-Decimal yet the dimension is displayed as fractional.

And here is a yet another one:

I just created a new style (Decimal) using decimal inches and created a dimension using it.

(1) The style does not appear in the drop down. BUT, if I click the dropdown button, Decimal shows up as selected.

(2) I go to the settings and Decimal shows up as using Fractional dimensions. Yet, the dimension I created uses Decimal dimensions.

Here’s another weird one. I did a dimension while the default style did fractions to a location at a decimal offset.

Then I changed the style from Default to Decimal. But in the Dropdown edit box, it still says “Default.” But in the dropdown window it says Default is selected. I have seen this before but do not know how to consistently reproduce it.

Styles have been my bane in V6 (which is funny because I do a course on how to use styles in Word).

Hi Miano,
Sorry that styles are causing you pain.

Are you able to repeat it? Did you close and reopen Rhino.
If not, keep your eyes open.

If yes, I need a file and “step by step” procedure.
The procedure you did before and included the steps & images was perfect.
Also include the date and SR version of Rhino 6 your are using.
I will try to reproduce it and get it logged.

Thank you for your help.
Mary Ann Fugier

I’ll try to get a step-by-step reproduction. The problem I have is I run into styles problems constantly so it’s hard to separate the issues. The thread starter is one I had see but it took me a while to figure out the steps.

In general it appears to me that there is a fundamental problem that the actual style in use, the properties panel, and the settings panel are not in synchronization with each other. This appears to happen in different ways. The difficulty is finding the steps that cause it to happen.

Rhino restarts often make the problem, go away. But that defeats the purpose of finding the sequence that causes the problem.

I am just listing them out to show the kinds of things I am trying to track down. Here’s one I saw for the first time yesterday.

I got Rhino into a state where:

  1. Select the text
  2. Change the text in the properties panel.
    [Text updated on the screen[
  3. Click outside of the text box.
    Text on the screen reverts to the original but the properties box still has the original text.

I have also wondered if there is something in the Rhino V5-V6 file conversion that causes some of these problems.

On the positive side, text/dimensions is the only place where I do have frustrating problems with V6.
(OK, I could add Make2D but I don’t use it that often).

More illustrative styles problem. I have a file created in V5. During the conversion, Rhino created its own style (Helvetica Regular).

I used selannotationstyle and grabbed all of them and used the properties panel to change the style to Room Names.

No change in appearance. So I click on one of the the text boxes and the style is Helvetica Regular

(Bug-the style did not change)

So now I change the style of the selected text box and change the style.

Now the properties says the style is Room Names.

But wait. It says the font is Century Schoolbook. But the text box clearly is not displaying in century schoolbook (Helvetica).

But, if I click another text box, then go back to the previous text box, it now says the style is Helvetica Regular.

I’m trying to create a cut down file that reproduces this. Apparently, the number of text boxes has an effect.

Here is a sequence and stripped down set of files that shows what I described in the previous post:

  1. Open Both Files
  2. Go to Problem Styles 11a
  3. Select ALL (should all be text of style Helvetica Regular.
  4. COPY
  5. Go to file Problem Styles 11b
  6. Paste
    Change the style to ROOM NAMES
    [No change in appearance]
  8. Select on of the text boxes.
  9. Properties says the style is Helvetica Regular.

You can change any the style in property for any text box, leave that text box, and return with the style not changing. You have to restart Rhino to get out of this.

Problem Styles 11a.3dm (6.1 MB) Problem Styles 11b.3dm (3.6 MB)

Hopefully I am not beating a dead horse here. Somehow I got rhino into a state where the the TEXT command was causing the DEFAULT style to have a text size of 24 while the DEFAULT style was defined to have a text size of 6.

This issue cleared by restarting Rhino.

Tell me if I am wrong but this kind of behavior makes me suspect the relevant code is written in C or a C variant.

Hi Miano,
This is all great information.
We appreciate it so much.

I will be looking at it today.
Stay tuned!

Mary Ann Fugier

Hi Miano,
I was able to duplicate this issue and log RH-58866

This is a complicated issue but getting these files and the procedure are invaluable to getting these issue fixed. I imagine that the issue is with adding the record to the file and creating the annotation style. Closing and reopening the file give it a chance to add the style correctly.

I also recorded this video with your instructions.
Let me know if I missed anything.

I think this is a major issue. I hope the developers will be able to sort out these annotation bugs soon. I will let you know when I hear back. Thank you again for your thoroughness.

Mary Ann Fugier