Small 3dm file won't open


I have a small 3dm file of a project I haven’t worked on for a few months that refuses to open. I’m currently on Rhino Mac and when I try to open the file it won’t go past the loading process. I get an infinite loading circle with a small thumbnail. Judging from the time it was saved I’m sure it was saved with Rhino 6 Win, which is what I have at the office. I have a 3dmbak file saved some 3 hours earlier, that opens fine. But since I don’t work on the project for some time I don’t remember the changes I made on that afternoon of work.

AP080_EP_CABREIROS_20200214.3dm (15.0 MB)


This is how it looks…

It opened without problems for me using Rhino for Win version Version 6 SR28.
Attached is a file saved with Save Small and Geometry only Also all viewports were in Wireframe mode. AP080_EP_CABREIROS_20200214_DC.3dm (5.0 MB)

And file saved immediately after opening. AP080_EP_CABREIROS_20200214_DCSave.3dm (15.0 MB)

1 Like

Thanks @davidcockey

My version 6 SR27. Your first file doesn’t have any layers, saved cplanes, saved views and some geometry seems to be missing. The second one has the exact same issue as the file I posted.
I tried on two Macs with the same version of rhino, same result. I will try to figure out what I have done in those 3 hours with the first file you sent. Thanks again for your help.


Hm - Chrome will not let me have this file… blocked as potentially malicious…


Not sure what that means, it it just a rhino file.
Just came back from my office where the file opened in rhino 6 sr27 without a problem. Saved a version without textures and plugin data but it still doesn’t work on the Mac.
I remembered that I previously had issues with this file caused by VisualArq: Can't select imported blocks

Hello - I don’t know what it means either - I can have the one that David posted back, no problem there… It shows layers, named views & CPlanes etc.
On mac, I cannot download either one…


Yeah! It works fine on Rhino for Windows but it refuses to open on Rhino for Mac. I’m not sure what is the problem but it isn’t related with a plugin. Might it be some geometry that is not supported on the mac version…

But can you open the last file that David posted back on a Mac?


RH-59554 File does not open on Mac Rhino


John Morse fixed a problem this week with the same symptoms:
The item is not open to public view because it used a customer file.
Unfortunately, whatever ails this file does not seem to be fixed by the fix.

Rhino does gripe about two missing fonts but I don’t think that has anything to do with this problem.

I did figure out a work-around.
I opened your file in Windows Rhino, and deleted the last three Layouts you had created with title blocks but nothing else. they had no details in them.
Now the file opens in V6 and V7 Mac.
AP080_EP_CABREIROS_20200214 less blank (7.6 MB)


Thanks @John_Brock!

At least I can open the file now! The last 3 layouts did have details. When I open the original final on windows the last 3 layouts have details pointing to the survey on the right of the model space. But those are easy to rebuild.


have you tried with Rescue3dmfile? just guessing

Yes, it doesn’t help.

RH-59554 is fixed in the latest Service Release Candidate