Slow render


#1

Hi Guys, my issue is that when I render the image, in the beginning it renders quite quick or I would say normal speed but when I create more renders, even test and a very small resolution image take hours. I think I might be blocking some folder where they are stored? I currently use Mac but I had this issue with windows and 3ds MAX before and when I deleted the drawings from temp file i worked fine. Do you guys know where the rendered images are stored on Mac? Or is is something else that is causing the issue?


(Brian James) #2

I’m not sure what the problem might be here but to my knowledge saved renderings will default to the last used finder location. @dan do you know if there is a temp directory that gets populated with renders regardless of if they are saved?

I could try to replicate the problem if I can see a model where this happens and know at what number of renderings saved you see the issue. I’d also ask if when you do see this issue, does restarting Rhino or the Mac itself solve the issue? I’m wondering if it is RAM related.


(Dan Belcher) #3

I do not think there is a place…at least 10 minutes of poking about in that code doesn’t reveal anything. @marlin can confirm or deny this.

I think your suspicion - @BrianJ - that it could be memory related has merit. It would be nice to reproduce this behavior if possible…but memory issues like this are often difficult to reproduce.


#4

Hi Brian, Dan,

Thank you both for your help. To answer your question Brian, restarting Rhino or Mac doesn’t help. I have checked the file again today and it still doesn’t work.(During 10 mins, it rendered 2 %). I opened different file with pretty much the same thing and it works just fine. I suspect if I was to render it few times, the same issue would appear. I set the same resolution on both (72 DPI, 100x100 pixels). I am attaching both files. An old one, which doesn’t render anymore and a new one.

Regards,
Aleksandra


#5

@BrianJ

This is dropbox link with the files.


(Brian James) #6

I think the issue might be the settings you have specified in the advanced render properties for that file. Go into the Render drop down menu>Render Properties>Advanced, then in the Render acceleration grids section change the value for screen grid, cell size back to 16 which is the default. You are using a value of 1000 there now in the file that has the speed issue. Also change the spotlight shadow grid size back to the default of 256 if you still have the problem. My hunch is that the screens grid cell size in pixels is the issue.

Here’s an online help document explaining what these settings control.
http://docs.mcneel.com/rhino/5/help/en-us/documentproperties/rhino_render_render_details.htm

@margaret I don’t find this specific page from the online docs when searching via the Rhino for Mac help. Can you check if I’m missing something or if we need to add the section?


#7

Thanks Brian,

I should have realised. Thank you, it works fine now.


#8

Thanks again. On the other note, my trial version is running out and I would like to buy one. I am not quite sure if it makes sense to buy WIP Rhino as I understand when all the tools are available later I would have to pay for a new licence again?


(Wim Dekeyser) #9

You cannot buy a WIP version. When you buy the latest release you also get access to the WIP.


(Brian James) #10

As Wim mentioned but if you have any questions about buying Rhino just email sales@mcneel.com or call 206-545-7000 too. Thanks!
http://www.en.na.mcneel.com/contact.htm


#11

Thank you Wim and BrianJ !